Bug 20552 - Encrypted Block Encountered algorithm should not reference Initialization Data
Encrypted Block Encountered algorithm should not reference Initialization Data
Status: RESOLVED FIXED
Product: HTML WG
Classification: Unclassified
Component: Encrypted Media Extensions
unspecified
All All
: P3 normal
: ---
Assigned To: David Dorwin
HTML WG Bugzilla archive list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-02 21:16 UTC by David Dorwin
Modified: 2013-04-30 01:54 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Dorwin 2013-01-02 21:16:19 UTC
http://dvcs.w3.org/hg/html-media/raw-file/tip/encrypted-media/encrypted-media.html#algorithms-enrypted-block step 4 refers to Initialization Data in the block or its parent and extracts the key ID from it. However, Initialization Data is not always the source of the current block's key identifier. ISO CENC is one such case.
Comment 1 David Dorwin 2013-04-24 21:47:55 UTC
I believe the issue is that initData does not always directly set the key ID for a given block. For example, with ISO CENC, the initData is a PSSH, but the key ID is set with another box.
Comment 2 David Dorwin 2013-04-24 21:48:12 UTC
We should fix this at the same time as bug 19788 and bug 19810, which removes another use of initData. With the combination, we do not need step 4 [1] and we don't need to support the case where there is no key ID. Thus, step 6.2 [2] can become "Let block key ID be the key ID for the current block."


[1] "If the block (or its parent entity) has Initialization Data, let block initData be that initialization data."
[2] "If block initData is not null and contains a key ID, let block key ID be that ID."
Comment 3 David Dorwin 2013-04-30 01:54:53 UTC
I removed the last references to Initialization Data in the Encrypted Block Encountered algorithm in https://dvcs.w3.org/hg/html-media/rev/dbfb9104f0ee after removing the uses of it by fixing bug 19788 and bug 19810.