Bug 20377 - [XT3TS] embedded-stylesheet-003
Summary: [XT3TS] embedded-stylesheet-003
Status: CLOSED FIXED
Alias: None
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: XSLT 3.0 Test Suite (show other bugs)
Version: Working drafts
Hardware: PC Windows NT
: P2 normal
Target Milestone: ---
Assignee: Abel Braaksma
QA Contact: Mailing list for public feedback on specs from XSL and XML Query WGs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-13 16:40 UTC by Tim Mills
Modified: 2013-02-05 16:50 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Mills 2012-12-13 16:40:45 UTC
The file embed003.xml is invalid with respect to the DTD.

"The 'xsl:version' attribute has an invalid value according to its data type."	

I suspect this is caused by

<!ATTLIST doc
		  xmlns:xsl CDATA #FIXED "http://www.w3.org/1999/XSL/Transform"
		  xsl:version CDATA #FIXED "'3.0'">

Shouldn't it be

<!ATTLIST doc
		  xmlns:xsl CDATA #FIXED "http://www.w3.org/1999/XSL/Transform"
		  xsl:version CDATA #FIXED "3.0">

to match

<doc xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xsl:version="3.0" >

Also, is

<!ATTLIST xsl:stylesheet 
		  version NMTOKEN #REQUIRED>

correct?
Comment 1 Michael Kay 2013-02-05 00:19:09 UTC
Corrected the fixed value of doc/@xsl:version.

I think the type given for xsl:stylesheet/@version is OK.
Comment 2 Tim Mills 2013-02-05 16:50:54 UTC
Thanks.