Bug 20320 - [Shadow]: Unclear how HTML form submission should work
[Shadow]: Unclear how HTML form submission should work
Status: RESOLVED DUPLICATE of bug 22443
Product: WebAppsWG
Classification: Unclassified
Component: Component Model
unspecified
PC Windows NT
: P2 normal
: ---
Assigned To: Dimitri Glazkov
public-webapps-bugzilla
:
Depends on:
Blocks: 15480
  Show dependency treegraph
 
Reported: 2012-12-10 05:09 UTC by Sergey G. Grekhov
Modified: 2013-07-17 20:21 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey G. Grekhov 2012-12-10 05:09:17 UTC
It's not clear from Shadow DOM specification should or should not form elements in ShadowDOM be submitted durint the form submit. Spec reads (https://dvcs.w3.org/hg/webcomponents/raw-file/tip/spec/shadow/index.html#html-forms): 'Because the form's ownerDocument is the shadow host's document, the form submission must continue to work as specified.'. Does it mean that if the form contains Shadow tree all form elements in the tree should be submitted when the form is submitted? The current Shadow DOM implementation in Google Chrome does not submit these elements. If this is a bug then I'll file a bug for the implementation. But anyway specification should more clearly specify should or should not form submit affect elements in shadow trees.
Comment 1 Dimitri Glazkov 2013-07-17 20:21:53 UTC

*** This bug has been marked as a duplicate of bug 22443 ***