Bug 20312 - [QT3TS] unparsed-text line ending corruptions
Summary: [QT3TS] unparsed-text line ending corruptions
Status: CLOSED FIXED
Alias: None
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: XQuery 3 & XPath 3 Test Suite (show other bugs)
Version: Last Call drafts
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: O'Neil Delpratt
QA Contact: Mailing list for public feedback on specs from XSL and XML Query WGs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-09 17:28 UTC by Michael Kay
Modified: 2013-01-02 19:56 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Kay 2012-12-09 17:28:09 UTC
The various data files in the unparsed-text collection are carefully designed to exercise different line endings. Unfortunately these do not survive transmission through CVS; CVS clients typically convert the line endings to the local platform default.

It might be possible to avoid this problem by marking the files as binary.

An example of a file that exhibits the problem is QT3-test-suite/fn/unparsed-text/text-plain-utf-16le-bom-lines.txt 

On my system (a MAC using the SmartCVS client), all the line endings have been normalized to 'xD'.
Comment 1 O'Neil Delpratt 2013-01-02 16:19:43 UTC
These files in question are marked as binary. Does the problem still exist?
Comment 2 Michael Kay 2013-01-02 19:56:36 UTC
I think the problem is now fixed.