Bug 20306 - [proposal] new "zone" tag (canvas and div hybrid)
Summary: [proposal] new "zone" tag (canvas and div hybrid)
Status: RESOLVED DUPLICATE of bug 20584
Alias: None
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal
Target Milestone: ---
Assignee: This bug has no owner yet - up for the taking
QA Contact: HTML WG Bugzilla archive list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-08 12:56 UTC by Alexei03a
Modified: 2013-01-23 11:18 UTC (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexei03a 2012-12-08 12:56:53 UTC
I came up with a full analogue DIV element. Has many differences. Behavior is the same as the IMG, Canvas and Video tag, the tag is only for content. Has the attributes width and height, like the Canvas. Ideal for inserting SVG content.

<!-- Width and Height must be 300x300 (with CSS values) -->
<zone width="256" height="256" style="width: 300px;">
  <img src="image.png" style="width: 100%; height: 100%;">
</zone>

"<zone>" - the fourth graphical HTML element. Why "zone", why not "area". Because the "area" occupied. In general, the idea is so easy and simple that I will not describe in detail. After all, the whole idea can be imported from Canvas, just have to imagine that it is possible to store other items.
Comment 1 Alexei03a 2012-12-09 02:53:20 UTC
In Russian Features:
- Тег содержит только два обязательных аттрибута: width и height.
- Стандартный размер этого тега - 300x150. Это вызвано тем, что элемент не должен менять свои границы от содержимого (т.е. контента).
- Поведение width и height такое же, как у canvas.
- Все CSS свойства применяются также, как у Canvas. Но при этом, может влиять на содержимое (но не влияет на сам элемент).
- Может иметь любое позиционирование (поведение как у любого другого элемента, содержимое должно вести себя также).
- Подходит для создания кастомных графических элементов, video-плееров и т.п.
- Можно встроить SVG данные (подобно IMG).
- Не требователен к скриптам. Достаточно использовать стили.
Comment 2 steve faulkner 2012-12-10 11:47:37 UTC
changed product to html.next
Comment 3 Marcos Caceres 2012-12-10 11:59:59 UTC
I'm confused. What's wrong with using a div? I'm not clear what the use case for this element is.
Comment 4 Robin Berjon 2013-01-21 16:00:08 UTC
Mass move to "HTML WG"
Comment 5 Robin Berjon 2013-01-21 16:02:53 UTC
Mass move to "HTML WG"
Comment 6 Alexei03a 2013-01-21 23:39:53 UTC
Make this bug as dublicate: https://www.w3.org/Bugs/Public/show_bug.cgi?id=20306
Comment 7 Robin Berjon 2013-01-23 11:15:35 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are
satisfied with this response, please change the state of this bug to CLOSED. If
you have additional information and would like the Editor to reconsider, please
reopen this bug. If you would like to escalate the issue to the full HTML
Working Group, please add the TrackerRequest keyword to this bug, and suggest
title and text for the Tracker Issue; or you may create a Tracker Issue
yourself, if you are able to do so. For more details, see this document:


   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: none
Rationale: There is nothing described in this proposal that cannot already be readily achieved using existing facilities in the stack.
Comment 8 Alexei03a 2013-01-23 11:18:46 UTC
This is old bug. 

New request: https://www.w3.org/Bugs/Public/show_bug.cgi?id=20584
Original, and is not dublicate!

*** This bug has been marked as a duplicate of bug 20584 ***