Bug 20267 - [XQ3.0] Support for new serialization options html-version and item-separator
[XQ3.0] Support for new serialization options html-version and item-separator
Status: CLOSED FIXED
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: XQuery 3.0
Last Call drafts
PC All
: P2 normal
: ---
Assigned To: Jonathan Robie
Mailing list for public feedback on specs from XSL and XML Query WGs
:
: 20413 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-06 11:09 UTC by Michael Kay
Modified: 2013-06-19 09:54 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Kay 2012-12-06 11:09:28 UTC
Two new serialization parameters have been introduced in the serialization specification: html-version and item-separator. These are not currently listed in the schema for serialization parameters, and in consequence they are not permitted to appear in XQuery output declarations.
Comment 1 Michael Kay 2012-12-17 16:19:36 UTC
Bug 20413 also mentions the omission of these parameters from Appendix C.1
Comment 2 Michael Kay 2012-12-17 16:20:04 UTC
*** Bug 20413 has been marked as a duplicate of this bug. ***
Comment 3 Jonathan Robie 2012-12-18 17:04:24 UTC
(In reply to comment #1)
> Bug 20413 also mentions the omission of these parameters from Appendix C.1

I will add these to Appendix C.1
Comment 4 Henry Zongaro 2012-12-18 18:06:00 UTC
The new serialization parameters are defined in the version of the schema for serialization parameters that's in CVS.  A copy appears in appendix B of the internal draft of Serialization 3.0.[1]  When the next public working draft of Serialization 3.0 is published, the schema will be refreshed.

[1] https://www.w3.org/XML/Group/qtspecs/specifications/xslt-xquery-serialization-30/html/Overview.html#serparams-schema (Member-only link)
Comment 5 Jonathan Robie 2012-12-20 22:32:08 UTC
(In reply to comment #3)
> (In reply to comment #1)
> > Bug 20413 also mentions the omission of these parameters from Appendix C.1
> 
> I will add these to Appendix C.1

Done in the checked-in version.