Bug 20159 - Introduce attributes for DOMString coercion
Summary: Introduce attributes for DOMString coercion
Status: RESOLVED DUPLICATE of bug 24581
Alias: None
Product: WebAppsWG
Classification: Unclassified
Component: WebIDL (show other bugs)
Version: unspecified
Hardware: PC Windows 3.1
: P2 normal
Target Milestone: ---
Assignee: Cameron McCormack
QA Contact: public-webapps-bugzilla
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-29 14:58 UTC by Anne
Modified: 2014-11-17 18:37 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anne 2012-11-29 14:58:58 UTC
1) An attribute that converts lone surrogates to U+FFFD as per http://lists.w3.org/Archives/Public/public-script-coord/2012OctDec/thread.html#msg82

2) An attribute to replace ByteString. We should probably not have ByteString as a distinct type per the arguments from Brendan in the thread above.
Comment 1 Boris Zbarsky 2012-11-29 16:11:37 UTC
I would actually prefer a distinct type for ByteString.  On the C++ side, ByteString needs to become some version of char*, while DOMString becomes a Unicode string.  These are typically different C++ classes, not just different conversion code.  And while it's possible to change the actual type of the object based on extended attributes, it feels pretty weird.
Comment 2 Anne 2014-11-17 18:37:34 UTC

*** This bug has been marked as a duplicate of bug 24581 ***