For the URL API I think we want to introduce URL.segments to get access to the path segments for URLs with their relative flag set. This is naturally an Array, but manipulation needs to affect the URL and the value that is being set needs to be percent-encoded (and required to be a string and such).
In http://dom.spec.whatwg.org/#elements we want Elements.prototype.queryAll to return this.constructor ideally.
(In reply to Anne from comment #1)
> In http://dom.spec.whatwg.org/#elements we want Elements.prototype.queryAll
> to return this.constructor ideally.
That is a terrible name. You have interfaces Elements and Element. Can you rename Elements to ElementList?
And the parameter name is plural, too, though it replresents a string. Can we instead call that relativeSelectorText?
I was correct in comment 1, but we should fix IDL. Not having it is not really an option. The other point here is that these methods on Array should not do instance checks, ideally they are generics. How do we indicate that?
Describe in steps what you want to have happen.