Bug 19927 - list-style-type does not validate
list-style-type does not validate
Status: RESOLVED FIXED
Product: CSSValidator
Classification: Unclassified
Component: CSS 3
CSS Validator
All All
: P2 major
: ---
Assigned To: This bug has no owner yet - up for the taking
qa-dev tracking
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-09 23:19 UTC by jswap
Modified: 2012-11-14 14:01 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jswap 2012-11-09 23:19:20 UTC
Test Case:
ul {list-style-type: none;}

Result:
Value Error : list-style-type none is not a list-style-type value : none
Comment 1 Jukka K. Korpela 2012-11-11 12:14:52 UTC
This only happens when testing against CSS level 3.

A related bug is that although the declaration list-style: none passes, it is (in CSS3 mode) incorrectly echoed in the “Valid CSS information” part as 

list-style-position : none none;
Comment 2 Jukka K. Korpela 2012-11-11 12:26:28 UTC
The problem is more serious than originally observed. Even list-style-type: disc is reported as an error in CSS 2.1. Moreover, e.g. list-style: decimal passes, but then “Valid CSS information” contains

list-style-position : decimal;
Comment 3 Yves Lafon 2012-11-14 14:01:20 UTC
All fixed now, the duplicate none is present only on prod servers, they will be upgraded soon (but should be ok on http://qa-dev.w3.org:8001/css-validator/ )
Thanks,