Bug 19847 - A strong VOTE for comments. An essential feature.
Summary: A strong VOTE for comments. An essential feature.
Status: RESOLVED MOVED
Alias: None
Product: webplatform.org
Classification: Unclassified
Component: Comments Extension (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: team-webplatform-admin list
QA Contact: public-webplatform-bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-03 19:55 UTC by Rick Hassen
Modified: 2013-04-01 19:46 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rick Hassen 2012-11-03 19:55:55 UTC
Hey all, I was talking with Peter and discovered that comments are considered a feature that might go away. I hope it stays as I think it is an essential feature. Please hear why - it allows a kind of collaboration and discussion on a larger scale - and in a different modality than when editing a document as well as giving those who may not feel confident to change a document to post questions or add an angle on a subject and allows for a more "conversation level" communication about the topic at hand. Oddly, I didn't realize Web Platform had this feature at first because the icon vanishes on my browser, BUT I was going to suggest it to Peter, which started the whole conversation and his suggestion that I put my thoughts into the bug tracker. 

Why, you may ask, was I going to suggest this feature. I've recently had an experiences while learning Mercurial, a terminal-based versioning program, which has a free book online which was also published by Orielly. The free online version has an additional feature, comments on each paragraph. I got more out of the comments than I did from the actual book. It was wonderful to have people debate points, disagree with the author and point to links that explained things. People could also post how they didn't understand something and then someone else would come along and answer the question. This, in particular was extremely helpful because, oftentimes I would have the same question. And it was answered there in the comments. Perhaps this could inspire someone who knows their stuff to edit the doc itself, but how would they know without the comments?


So, here is a link to the aforementioned example of this working really well: http://hgbook.red-bean.com/read/mercurial-in-daily-use.html

And if you don't use Mercurial, I highly suggest it - its much faster than Git and Subversion...though you can find debates on the finer points of why some users like one versioning program over another in the comments of this book! 

Seriously, on-page-contextual-commenting allows one to have a sense of community and conversation as well for a more direct (q&a) communication when you need/want it, since one can ignore the comments if you want.

Thanks for considering keeping this feature and please feel free to contact me if there is anything I can do to help support or develop this feature.

(UX/UI note: I think that the comments should be nearly invisible, but there for those who want it, when they want it)
Comment 1 David Kirstein (Frozenice) 2012-11-03 21:49:51 UTC
I guess this bug can function as a base for discussion about comments / no comments. Just adding some resources here:
* Check currently open bugs for the Comments extension (maybe things get better when they get fixed): https://www.w3.org/Bugs/Public/buglist.cgi?product=webplatform.org&component=Comments%20Extension&resolution=---&list_id=1620
* I just found out about this page, it's a log of the comments: http://docs.webplatform.org/wiki/Special:Log/comments
Comment 2 Jonathan Garbee 2012-11-04 14:44:30 UTC
What I'm thinking is the current comment system get removed.  It is simply hell to administer even with the Special:Log (thanks fr0zenice) to show you all the latest updates.

What we would do initially is have a section of the new bugtracker for comments on the site, then we would figure out how to build a front-end to the tracker as a new comment system inline with the wiki almost how the current one is set to display.  From there we could just have a "comment" actually generate a new report in the tracker.  We could even have the UX allow for commenting in the frontend as well that way everything is there when it is open.  As an issue is resolved we can mark it as such in the trakcer and then only the title of the issue is displayed on the front-end along with some indication that something is done or a decision on whatever the issue was has been made.

This keeps the front-end clean and *easily* administrated compared to what we have now.  In order to keep the comment system as it currently is would require some extra UI work in order to make it clean and easy to admin.  Replacing with a bugtracker section really does seem like the best idea to me since it centralizes all feedback on content into a single area.

I will have more ideas on exactly how this workflow will work in the mailing list later this week for more discussion.  I will comment back with a link to that post in the archive once it is out.
Comment 3 Jonathan Garbee 2012-11-06 15:26:28 UTC
The email [1] has been published to the mailing list with a bit more detail on what is planned.  Discussion still needs to be made around this proposal which will probably happen at today's telcon along with more email in the list later on.

[1] http://lists.w3.org/Archives/Public/public-webplatform/2012Nov/0029.html
Comment 4 Jonathan Garbee 2013-04-01 19:46:46 UTC
New location: http://project.webplatform.org/commentsextension/issues/3