Bug 19805 - Restriction to only use initData in createSession is too restrictive
Summary: Restriction to only use initData in createSession is too restrictive
Status: RESOLVED FIXED
Alias: None
Product: HTML WG
Classification: Unclassified
Component: Encrypted Media Extensions (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: David Dorwin
QA Contact: HTML WG Bugzilla archive list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-31 22:11 UTC by Joe Steele
Modified: 2013-04-24 22:35 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Steele 2012-10-31 22:11:15 UTC
I would like to see this note removed from the createSession() method --

"Note: cdm must not use any data, including media data, not provided via initData." 

This is too restrictive, since the CDM may do things like signing the key request with an embedded key, which would add data not provided by initData.
Comment 1 David Dorwin 2012-10-31 22:43:06 UTC
This was intended to refer to media data or any other media/stream-specific values. The intent is that all media-identifying values used to create a license should be available in the needkey event and could be constructed by the application without relying on the stream.

This intent seems independent of your use case. I think s/data/media data/ would address both concerns. What do you think?
Comment 2 David Dorwin 2012-10-31 22:51:39 UTC
Oops, that replacement doesn't make sense. How about this?

"Note: cdm must not use any stream-specific data, including media data, not provided via initData."
Comment 3 Joe Steele 2012-11-01 16:04:03 UTC
That text is much better. Now I understand the intent.
Comment 4 David Dorwin 2012-11-01 16:45:29 UTC
Will update in a future edit.
Comment 5 Adrian Bateman [MSFT] 2013-04-24 22:35:13 UTC
Fixed -> https://dvcs.w3.org/hg/html-media/rev/70e0d6713156