Bug 19777 - Grammar issue with qualified operations
Grammar issue with qualified operations
Status: RESOLVED DUPLICATE of bug 18424
Product: WebAppsWG
Classification: Unclassified
Component: WebIDL
unspecified
PC All
: P2 normal
: ---
Assigned To: Cameron McCormack
public-webapps-bugzilla
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-30 13:13 UTC by Robin Berjon
Modified: 2012-10-31 08:49 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Berjon 2012-10-30 13:13:58 UTC
If you track through the grammar, you get (removing paths irrelevant to this problem):

InterfaceMember → AttributeOrOperationOrIterator
AttributeOrOperationOrIterator → Qualifier AttributeOrOperationRest
Qualifier → "static" | "stringifier"
AttributeOrOperationRest → OperationRest
OperationRest → OptionalIdentifier "(" ArgumentList ")" ";"

So putting all of that together, it's impossible to specify a return type for static or stringifier operations. It should probably be ReturnType OperationRest in there.
Comment 1 Peter Van der Beken 2012-10-31 08:49:14 UTC

*** This bug has been marked as a duplicate of bug 18424 ***