Bug 19752 - Add sandboxed pointer lock flag to HTML Sandboxing
Add sandboxed pointer lock flag to HTML Sandboxing
Status: RESOLVED DUPLICATE of bug 19773
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec
unspecified
Other other
: P3 normal
: ---
Assigned To: Silvia Pfeiffer
HTML WG Bugzilla archive list
:
Depends on: 18647 19773
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 05:45 UTC by Silvia Pfeiffer
Modified: 2013-01-23 11:21 UTC (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Silvia Pfeiffer 2012-10-29 05:45:19 UTC
+++ This bug was initially created as a clone of Bug #18647 +++

Created to merge https://github.com/w3c/html/commit/0e5f355bd059d8857a44505757da025f21e2efb7, which has been parked in feature/whatwg_iframe_pointer_lock branch.



Pointer Lock API [1] adds capability that should be restricted by a sandbox flag unless an iframe is marked explicitly with sandbox="allow-pointer-lock"

Rough edit suggestion to HTML:
http://dev.w3.org/html5/spec/origin-0.html#sandboxing

Add a section for The sandboxed pointer lock flag
+ "The sandboxed pointer lock flag
+  This flag prevents content from using the Pointer Lock API"
   with link to http://www.w3.org/TR/pointerlock/

Add a new flag parsing item:
After the text: "When the user agent is to parse a sandboxing directive ..."
Add
+ "The sandboxed pointer lock flag, unless tokens contains the allow-pointer-lock keyword"


[1] http://dvcs.w3.org/hg/pointerlock/raw-file/default/index.html
Comment 1 Robin Berjon 2013-01-21 15:57:52 UTC
Mass move to "HTML WG"
Comment 2 Robin Berjon 2013-01-21 16:00:33 UTC
Mass move to "HTML WG"
Comment 3 Robin Berjon 2013-01-23 11:21:28 UTC

*** This bug has been marked as a duplicate of bug 19773 ***