Bug 19480 - [QT3TS] CastAsNamespaceSensitiveType-5
[QT3TS] CastAsNamespaceSensitiveType-5
Status: CLOSED DUPLICATE of bug 19479
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: XQuery 3 & XPath 3 Test Suite
Working drafts
PC Windows NT
: P2 normal
: ---
Assigned To: O'Neil Delpratt
Mailing list for public feedback on specs from XSL and XML Query WGs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 16:39 UTC by Tim Mills
Modified: 2012-11-08 14:44 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Mills 2012-10-11 16:39:08 UTC
Since this function is declared as returning a string, function argument conversion, static type analysis spots that  the declared return type (string) of the function does not match the actual type returned (NOTATION).  It therefore raises XPTY0004.

I think the intention of the test was to spot casting of the <tag>xs:integer</tag> to xs:NOTATION, and thus suggest removing "as xs:string".


     declare function local:clarkname($q as xs:NOTATION) as xs:string {
       $q
     };

     local:clarkname(<tag>xs:integer</tag>)
Comment 1 O'Neil Delpratt 2012-11-08 14:26:42 UTC
This bug issue has been taken over by the fix made from issue #19479

*** This bug has been marked as a duplicate of bug 19479 ***
Comment 2 Tim Mills 2012-11-08 14:44:23 UTC
Confirmed fixed.  Thanks.