Bug 19285 - function-lookup() is a bit verbose
function-lookup() is a bit verbose
Status: RESOLVED FIXED
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: XPath 3.0
Working drafts
PC All
: P2 enhancement
: ---
Assigned To: Jonathan Robie
Mailing list for public feedback on specs from XSL and XML Query WGs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 11:03 UTC by Andrew Welch
Modified: 2012-10-05 11:36 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Welch 2012-10-05 11:03:35 UTC
Hi,

The function-lookup() function name is a bit too long and unwieldy eg

fold-left(function-lookup($my-qname, 2).....

Is it possible to also have a shorthand version of just f() ?  

fold-left(f($my-qname, 2).....

...or some other single character symbol?

thanks
andrew
Comment 1 Michael Kay 2012-10-05 11:33:19 UTC
Try

<xsl:variable name="f" select="function-lookup#2"/>


then

fold-left($f($my-qname, 2))
Comment 2 Andrew Welch 2012-10-05 11:36:51 UTC
heh, great... thanks : )