Bug 19283 - Investigate IDNA2003 separators
Investigate IDNA2003 separators
Status: RESOLVED DUPLICATE of bug 18910
Product: WHATWG
Classification: Unclassified
Component: URL
unspecified
PC Windows 3.1
: P2 normal
: Unsorted
Assigned To: Anne
sideshowbarker+urlspec
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 08:47 UTC by Mathias Bynens
Modified: 2012-12-21 14:30 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Bynens 2012-10-05 08:47:56 UTC
Continuing the discussion in https://github.com/bestiejs/punycode.js/issues/11, I wrote a simple test that sets URLs with IDNA2003 separators U+002E, U+3002, U+FF0E, U+FF61 as the `src` of an `iframe` element in memory, and then returns the resulting normalized `src`.

Chrome, Safari, Firefox:

http://xn--maana-pta.com/
http://xn--maana-pta.com/
http://xn--maana-pta.com/
http://xn--maana-pta.com/

Opera:

http://mañana.com/
http://mañana.com/
http://mañana.com/
http://mañana.com/

It seems all browsers tested so far support these separators for backwards compatibility. I haven’t tested IE yet, or older versions of the other browsers.
Comment 1 Mathias Bynens 2012-10-05 08:51:39 UTC
Uploading the attachment failed for some reason, so I’ve uploaded the test here: http://mathias.html5.org/tests/url/idna2003-separators/
Comment 2 Mathias Bynens 2012-10-05 12:47:39 UTC
I’ve updated the test so that it displays PASS if the browser supports IDNA2003 separators and FAIL otherwise.

IE9 supports these separators as well, so it looks like they should be included in the URL spec.
Comment 3 Anne 2012-12-21 14:30:58 UTC

*** This bug has been marked as a duplicate of bug 18910 ***