Bug 19055 - HTML5 Lacks a Way to Programmatically-Determine Missing Text Alternatives
HTML5 Lacks a Way to Programmatically-Determine Missing Text Alternatives
Status: RESOLVED FIXED
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec
unspecified
PC All
: P3 enhancement
: ---
Assigned To: This bug has no owner yet - up for the taking
HTML WG Bugzilla archive list
http://dev.w3.org/html5/spec/text-lev...
: a11y, a11y_text-alt
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 22:01 UTC by contributor
Modified: 2013-03-19 09:56 UTC (History)
10 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2012-09-25 22:01:22 UTC
This was was cloned from bug 9213 as part of operation LATER convergence.
Originally filed: 2010-03-08 16:39:00 +0000
Original reporter: Laura Carlson <laura.lee.carlson@gmail.com>

================================================================================
 #0   Laura Carlson                                   2010-03-08 16:39:42 +0000 
--------------------------------------------------------------------------------
SPEC SECTIONS:

Images whose contents are not known [1]
Guidance for conformance checkers [2] 

BUG DESCRIPTION:

HTML5 Lacks a way to programmatically determine [3] where images whose contents are not known to be detected and labeled as such. Consider creating a "missing" attribute.

OUTCOMES OF FIXING THE BUG:

* A "missing" attribute would provide a practical method of detection, handling, and future improvement. 

* Possibilities for crowdsourcing exist with the addition of a "missing" attribute It should be reasonably easy to maintain a hash of images with @missing and the obtain value(s) submitted for them. We would need a canonical URI (or in HTML5, an 'origin') for the document and an ID for the image, but if we had a service (either local or remote) that accepted the URI and its @alt value, then users of AT could associate the values as needed. The worst case is that nothing is returned. (The second-worst case is that it's a bogus value, but the owner of the document could manage submitted @alt content.) The pointer to where to send this information could be in a <link> element, and it could be a standard HTTP request, or a transaction using the HTML5 Database object. It could be hosted locally, or by a third party. This idea would get around one of the biggest problems with around images: that we can see something is wrong with someone else's content, but can't do anything about it. With this method people who know what they're doing could directly impact the accessibility of another organization's content. It also helps image gallery sites since the image creator or anyone who views the image could propose usable @alt with an extremely low-bandwidth solution. If this method is used then we'd have to specify @missing, and that any image with that attribute also needs an ID, or they wouldn't be associable by the UA/AT. Then we'd need to specify the @rel attribute for the <link> to the mechanism for associating the @alt. 

* Would be valid and in accord with Accessibility Coordination Group's "Consensus Resolutions on Text alternatives in HTML 5". [4] 

ATTRIBUTE NAME:

If it is not too long, "notextalternative" could be a suitable name instead of "missing" for this attribute. The image could be missing any one of text alternatives in the set of valid options for conformance checkers. 

REFERENCES:

http://dev.w3.org/html5/spec/text-level-semantics.html#unknown-images [1]
http://dev.w3.org/html5/spec/text-level-semantics.html#guidance-for-conformance-checkers [2]
http://www.w3.org/TR/UNDERSTANDING-WCAG20/conformance.html#uc-programmatically-determined-head [3]
http://www.w3.org/2009/06/Text-Alternatives-in-HTML5 [4] 


HTML5 ISSUE AND CHANGE PROPOSAL:

This is associated with HTML TRACKER ISSUE-31 
http://www.w3.org/html/wg/tracker/issues/31

Change Proposal: Replace img Guidance for Conformance Checkers:
http://www.w3.org/html/wg/wiki/ChangeProposals/ImgElement20090126
================================================================================
 #1   Maciej Stachowiak                               2010-03-23 06:14:58 +0000 
--------------------------------------------------------------------------------
As far as I can tell, the text here requires validators to report an error if alt is absent and none of the conditions applies:
http://dev.w3.org/html5/spec/Overview.html#guidance-for-conformance-checkers

"A conformance checker must report the lack of an alt attribute as an error unless one of the conditions listed below applies:..."

In particular, the set of conditions there seems just as checkable as the set in the Change Proposal. Therefore I think this bug should be resolved as WORKSFORME.
================================================================================
 #2   Ian 'Hixie' Hickson                             2010-04-02 00:08:35 +0000 
--------------------------------------------------------------------------------
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Did Not Understand Request
Change Description: no spec change
Rationale: I don't understand. Could you restate the bug description? Are you asking for a way to programmatically detect (e.g. from JS?) that an image is missing alt text?
================================================================================
 #3   Laura Carlson                                   2010-11-30 13:16:46 +0000 
--------------------------------------------------------------------------------
*** Bug 11441 has been marked as a duplicate of this bug. ***
================================================================================
 #4   Martin Kliehm                                   2010-12-07 16:25:29 +0000 
--------------------------------------------------------------------------------
Although a @missing attribute is not part of the text alternatives package, the bug-triage sub-team doesn't think this is an accessibility task force priority.
================================================================================
 #5   Laura Carlson                                   2011-06-07 08:09:22 +0000 
--------------------------------------------------------------------------------
A missing attribute would provide a practical method of detection, handling, and repair of missing text alternatives, after a conscious decision has been made by the author to deliberately publish images without text alternatives. It would:

* Allow an image without alt text be honestly labeled for it is: missing, incomplete, lacking substance.
* Affirm that the author did not (and does not intend to) provide a text alternative.
* Provide a machine checkable mechanism to locate missing alt text/enable tools to quickly discern where "missing" has been used.
* Afford a practical means to mitigate damages after all else has failed, allowing for crowdsourcing or metadata repair. AT would be at liberty to apply a crowdsourced definition, to scour image metadata or or both, since the AT knows that the author didn't apply a text alternative, it can inform the user as to the potential deficiency in the located text(s).
* Support ethical accountability by promoting the development of responsible tools and by advocating an effective enabling environment. 

Jan Richards explained how this could work [1]:

1. the author drag-and-drops an image into an authoring tool (bypassing  the usual insert dialog)
2. the authoring tool has implemented a "live" accessibility checker (not  required by ATAG but a nice feature), so the image is immediately given  a blue squiggly underline (similar to red underlining of spelling  errors) to indicate no @alt value has been set.
3. BUT the author ignores the underlining, saves and close the document.
4. BUT the authoring tool has an accessibility option set to use the  "missing" mechanism to validate, so when the author has failed to  address the accessibility issue and the content is being closed, the  tool adds @alt=" " and the "missing" mechanism. (Ordinarily adding " " to the @alt would be considered a repair of the  alternative text, but the missing mechanism tells user agents to ignore it...so ATAG2 B.2.4.3 is met).

It is possible to require a set of programmatically valid options which maintains the integrity of the markup and aids accessibility while addressing business needs. 

--
[1] http://lists.w3.org/Archives/Public/public-html/2009Aug/1009.html
================================================================================
 #6   Ian 'Hixie' Hickson                             2011-06-13 23:43:33 +0000 
--------------------------------------------------------------------------------
Before it would be reasonable to deploy something like this in HTML proper, we should first determine whether this is something that authors are likely to actually use.

I would recommend defining a class name, e.g. "alt-missing-intentionally", that could be handled in the way described above, and then encouraging people who need this feature to use that for now. If it takes off, then it would make sense to anoint it in the spec.

EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Partially Accepted
Change Description: none yet
Rationale: I have marked this LATER so that we can look at this again once people have had a chance to demonstrate the authoring demand for this feature.
================================================================================
Comment 1 Silvia Pfeiffer 2013-03-19 09:56:27 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If
you are satisfied with this response, please change the state of
this bug to CLOSED. If you have additional information and would
like the Editor to reconsider, please reopen this bug. If you would
like to escalate the issue to the full HTML Working Group, please
add the TrackerRequest keyword to this bug, and suggest title and
text for the Tracker Issue; or you may create a Tracker Issue
yourself, if you are able to do so. For more details, see this
document:   http://dev.w3.org/html5/decision-policy/decision-policy-v2.html

Status: Accepted

Change Description: The generator-unable-to-provide-required-alt attribute was introduced to address this and Issue-31 is already closed.

Rationale: The attribute provides guidance for conformance checkers.