Bug 19049 - Provide access to global accessibility settings
Summary: Provide access to global accessibility settings
Alias: None
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal
Target Milestone: ---
Assignee: This bug has no owner yet - up for the taking
QA Contact: HTML WG Bugzilla archive list
Keywords: a11y, a11ytf
: 13619 (view as bug list)
Depends on:
Reported: 2012-09-25 22:00 UTC by contributor
Modified: 2013-04-17 13:25 UTC (History)
9 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2012-09-25 22:00:12 UTC
This was was cloned from bug 13619 as part of operation LATER convergence.
Originally filed: 2011-08-03 18:32:00 +0000
Original reporter: Greg Lowney <gcl-0039@access-research.org>

 #0   Greg Lowney                                     2011-08-03 18:32:02 +0000 
HTML5 should define a standard, platform-independent way for content to query the user agent's accessibility settings, and by extension platform settings that are known to the user agent. This is one aspect of allowing HTML-based content and applications provide accessibility support equal to and consistent with the platform and native applications, and can avoid situations where their default settings make HTML-based applications inaccessible.

We note there are privacy concerns that must be addressed. For example, companies should not be able to infer the disabilities of visitors to their web site by querying the user's accessibility settings. However, this is just one example of a broader issue that needs to be addressed, and is covered by bug 13617. 

Use case: Yev turns on his operating system's High Contrast option. This option is supported by all major operating systems and tells software the user wants high contrast between foreground and background. In his browser he loads a web-based flow chart editor that displays all its document content in an HTML5 canvas element. The flow chart editor wants to detect when the user has high contrast mode turned on so it can adjust its graphical display appropriately. Because it's designed to run on any browser and any operating system, it needs a platform-independent means of querying this setting.

Use case: Amanda has turned on the "Show Extra Keyboard Help" option in the Windows Control Panel, which tells all software that she wants any and all options that enhance keyboard access to be automatically enabled. Her web browser responds to this setting by, for example, always displaying the underlined access keys in menu and control labels. She would like web pages and web apps to also respond to this setting, even if they're creating custom controls.
 #2   Anne                                            2011-08-15 16:33:00 +0000 
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document: <http://dev.w3.org/html5/decision-policy/decision-policy.html>.

Status: Rejected
Change Description: no spec change
Rationale: This is out of scope for HTML.
 #3   Michael Cooper                                  2012-01-11 18:53:08 +0000 
Bug triage sub-team changing resolution from invalid to later. We see this as a feature request. We're not sure if this should be dealt with by HTML, WebApps, or another entity. But the accessibility community would like to take this up further down the road, so for the moment marking the bug as later and not moving to another product yet seems to make sense.
Comment 1 Ian 'Hixie' Hickson 2013-03-21 21:52:27 UTC
*** Bug 13619 has been marked as a duplicate of this bug. ***
Comment 2 Michael Cooper 2013-04-17 13:25:44 UTC
This issue is being addressed by IndieUI: User Context https://dvcs.w3.org/hg/IndieUI/raw-file/default/src/indie-ui-context.html so closing in HTML