Bug 19047 - how about minlength? i'd like to see certain fields to have a minimum amoung of characters for validation
how about minlength? i'd like to see certain fields to have a minimum amoung ...
Status: RESOLVED LATER
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec
unspecified
Other other
: P3 normal
: ---
Assigned To: This bug has no owner yet - up for the taking
HTML WG Bugzilla archive list
http://www.whatwg.org/specs/web-apps/...
:
: 18140 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 21:59 UTC by contributor
Modified: 2013-03-11 16:46 UTC (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2012-09-25 21:59:51 UTC
This was was cloned from bug 10053 as part of operation LATER convergence.
Originally filed: 2010-06-30 02:41:00 +0000

================================================================================
 #0   contributor@whatwg.org                          2010-06-30 02:41:03 +0000 
--------------------------------------------------------------------------------
Section: http://www.whatwg.org/specs/web-apps/current-work/#the-maxlength-attribute

Comment:
how about minlength? i'd like to see certain fields to have a minimum amoung
of characters for validation

Posted from: 209.99.13.239
================================================================================
 #1   Ian 'Hixie' Hickson                             2010-08-28 04:48:30 +0000 
--------------------------------------------------------------------------------
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: no spec change
Rationale: Maybe one day. Let's let the browsers catch up first.
================================================================================
 #2   Ian 'Hixie' Hickson                             2010-09-10 09:39:49 +0000 
--------------------------------------------------------------------------------
*** Bug 10308 has been marked as a duplicate of this bug. ***
================================================================================
 #3   Mounir Lamouri                                  2011-01-26 20:56:51 +0000 
--------------------------------------------------------------------------------
*** Bug 11870 has been marked as a duplicate of this bug. ***
================================================================================
 #4   Aryeh Gregor                                    2011-01-27 01:02:51 +0000 
--------------------------------------------------------------------------------
Note that minlength="n" is equivalent to pattern=".{n}".  Not clear if it's common enough to really need special handling.
================================================================================
 #5   Mounir Lamouri                                  2011-01-27 15:25:48 +0000 
--------------------------------------------------------------------------------
(In reply to comment #4)
> Note that minlength="n" is equivalent to pattern=".{n}".  Not clear if it's
> common enough to really need special handling.

No, minlength="n" isn't equivalent too pattern=".{n}". @pattern should only be used for specific cases given that it removes all semantic.

In addition of passwords fields that require a minimum length (I guess that would be the primary use case), minlength could be used for field that require a specific length in association with maxlength (with maxlength and minlength having the same value).
================================================================================
Comment 1 Robin Berjon 2013-03-11 16:46:27 UTC
*** Bug 18140 has been marked as a duplicate of this bug. ***