Bug 19046 - Add default button option/attribute for forms
Add default button option/attribute for forms
Status: RESOLVED LATER
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec
unspecified
PC Windows XP
: P3 normal
: ---
Assigned To: This bug has no owner yet - up for the taking
HTML WG Bugzilla archive list
: a11y, a11ytf
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 21:59 UTC by contributor
Modified: 2012-09-25 22:26 UTC (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2012-09-25 21:59:36 UTC
This was was cloned from bug 9280 as part of operation LATER convergence.
Originally filed: 2010-03-19 12:10:00 +0000
Original reporter: Jonathan Avila <jon.avila@ssbbartgroup.com>

================================================================================
 #0   Jonathan Avila                                  2010-03-19 12:10:18 +0000 
--------------------------------------------------------------------------------
Please consider adding a default button option/attribute for forms.  I believe this would simplify a lot of form interaction for users of assistive technology and users who rely off of the keyboard alone.  Currently different browsers
handle this differently and there is no specific method for assigning which button will be activated when enter is pressed in a form field other than a button that works across browsers.
================================================================================
 #1   Ian 'Hixie' Hickson                             2010-04-01 22:24:03 +0000 
--------------------------------------------------------------------------------
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: no spec change
Rationale: The spec defines how default buttons are to be selected:

   http://www.whatwg.org/specs/web-apps/current-work/multipage/association-of-controls-and-forms.html#default-button

I agree that we should probably make it possible to explicitly pick a button as the default. However, we've already added quite a lot to the forms part of the spec and not all of it has been widely implemented yet, so I'd rather we wait some more before adding such a feature.
================================================================================
 #2   Michael Cooper                                  2010-08-31 14:06:11 +0000 
--------------------------------------------------------------------------------
http://lists.w3.org/Archives/Public/public-html-a11y/2010Aug/0124.html

The bug triage sub-team believes the HTML A11Y TF should take up this bug. Additional notes may follow in a separate comment.
================================================================================
 #3   Michael Cooper                                  2010-09-02 13:15:05 +0000 
--------------------------------------------------------------------------------
Bug triage sub-team says declarable default submit button would be a good a11y enhancement.
================================================================================
 #4   Anne                                            2011-08-14 09:59:35 +0000 
--------------------------------------------------------------------------------
*** Bug 13320 has been marked as a duplicate of this bug. ***
================================================================================