Bug 18988 - Allow explicit grouping of <dt> and <dd> elements
Summary: Allow explicit grouping of <dt> and <dd> elements
Status: RESOLVED WONTFIX
Alias: None
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec (show other bugs)
Version: unspecified
Hardware: PC Linux
: P3 enhancement
Target Milestone: ---
Assignee: This bug has no owner yet - up for the taking
QA Contact: HTML WG Bugzilla archive list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-24 13:10 UTC by Dave Sparks
Modified: 2015-06-26 05:38 UTC (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Sparks 2012-09-24 13:10:41 UTC
I have a problem which would be best solved by an element, analogous to <tbody>, which could optionally be used to explicitly group <dt> and <dd> elements.

One of my pages includes a list of events, which I would like to describe using microdata.  The details of each event are spread across a <dt> element and several <dd> elements.  No one element in the page includes all, and only, the details of a single event.

My first attempt to add microdata used the itemscope and itemtype attributes on the <dt> element, with an itemref attribute referencing the several <dd> elements.  Not only is this cumbersome, but Google seems to ignore itemref.

I now use <meta> elements, and an empty <a> element, in the <dt> element, for the microdata I want to present to Google.  This means that data is needlessly duplicated.

An alternative would be to use a separate <dl> element to enclose the details of each event, but this obfuscates the underlying structure.

The page in question is at
<http://www.potoc.dandasparks.org.uk/txt/events.html>, or more readably at
<http://potoc.dandasparks.org.uk/txt(raw)/events.html>
Comment 1 Edward O'Connor 2012-09-24 16:57:36 UTC

*** This bug has been marked as a duplicate of bug 18287 ***
Comment 2 Dave Sparks 2012-09-24 17:11:15 UTC
bug 18287 was resolved as "If there's a limitation with the styling, we should fix CSS".

That doesn't apply to this bug.  Maybe the limitation should be addressed in the microdata specification, but that's still an HTML5 issue.
Comment 3 Robin Berjon 2013-04-05 14:07:23 UTC
This mentions microdata, but it really is an HTML bug.
Comment 4 Michael[tm] Smith 2015-06-16 12:04:30 UTC
This has been discussed years ago and it's clear there's never going to be sufficient implementer interest in this, nor have there been other commentors weighing in to voice support. So there's not much point in continuing to keep an issue for this open here.