Bug 18929 - MediaStream as source for media elements
Summary: MediaStream as source for media elements
Status: RESOLVED DUPLICATE of bug 23775
Alias: None
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec (show other bugs)
Version: unspecified
Hardware: PC Linux
: P2 normal
Target Milestone: ---
Assignee: Silvia Pfeiffer
QA Contact: HTML WG Bugzilla archive list
Depends on:
Reported: 2012-09-20 07:25 UTC by Stefan Hakansson LK
Modified: 2014-04-08 01:06 UTC (History)
8 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Hakansson LK 2012-09-20 07:25:49 UTC
The Media Capture TF is defining a concept called MediaStreams ([1]) to handle live media from cameras and microphones (amongst other things).

There has been discussions on how to use MediaStream's as sources for media (audio, video) elements.

Currently, it seems that two ways will be supported:
* use the src attribute of the media element by createObjectURL for MediaStream
* a new objSource attribute on the media element that allows direct assignment of a MediaStream as source

The question that arises is where to specify objSource (and its interaction with other things in the media element). One option is as en extension to the media element in [1], and the other would be in the HTML5 spec.

Silvia Pfieffer, in an off-line discussion, indicated that filing a bug would be the best way to get this discussed, so here it is!

Stefan (Media Capture TF co-chair)

[1] http://dev.w3.org/2011/webrtc/editor/getusermedia.html
Comment 1 Erika Doyle Navara 2012-10-19 19:16:35 UTC
Moving this to HTML.next as we work to lock down HTML5.0 for CR.
Comment 2 Robin Berjon 2013-01-21 15:58:43 UTC
Mass move to "HTML WG"
Comment 3 Robin Berjon 2013-01-21 16:01:29 UTC
Mass move to "HTML WG"
Comment 4 Silvia Pfeiffer 2013-06-06 05:27:35 UTC
Sorry about the long delay in discussing this. I believe the questions has been answered towards using the @src attribute both in Firefox and Chrome implementations. Do we require any further discussion of this here or can we just leave it to the Media Capture TF to continue resolving this?
Comment 5 Silvia Pfeiffer 2014-04-08 01:06:35 UTC

*** This bug has been marked as a duplicate of bug 23775 ***