Bug 18772 - Should getAllResponseHeaders() end with \r\n?
Should getAllResponseHeaders() end with \r\n?
Status: RESOLVED WORKSFORME
Product: WebAppsWG
Classification: Unclassified
Component: XHR
unspecified
All All
: P2 normal
: ---
Assigned To: Anne
public-webapps-bugzilla
needs test
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 18:46 UTC by Ms2ger
Modified: 2012-10-09 17:27 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ms2ger 2012-09-04 18:46:07 UTC
The spec says

> Return all the HTTP headers, excluding headers that are a case-insensitive
> match for Set-Cookie or Set-Cookie2, as a single string, with each header
> line separated by a U+000D CR U+000A LF pair, excluding the status line,
> and with each header name and header value separated by a U+003A COLON
> U+0020 SPACE pair.

That seems to suggest "no", but is that intentional?
Comment 1 Anne 2012-10-09 14:59:08 UTC
Yes. Makes splitting work better. Might want to test this though, but that is not a bug in the standard.