This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 18769 - Specifying align but not position behavior is not intuitive
Summary: Specifying align but not position behavior is not intuitive
Status: RESOLVED FIXED
Alias: None
Product: TextTracks CG
Classification: Unclassified
Component: WebVTT (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: Philip J├Ągenstedt
QA Contact: This bug has no owner yet - up for the taking
URL:
Whiteboard: v1
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-03 22:02 UTC by Simon Pieters
Modified: 2014-05-12 00:32 UTC (History)
5 users (show)

See Also:


Attachments
default position when align change (63.89 KB, image/jpeg)
2012-09-12 23:57 UTC, Silvia Pfeiffer
Details

Description Simon Pieters 2012-09-03 22:02:00 UTC
Consider specifying a cue an specifying just the align setting:

00:00:00.000 --> 00:00:10.000 align:end
Hello

It seems natural to expect that the cue will be right aligned *and* positioned to the right of the video viewport. What happens right now is that the position setting is still 50% and the cue grows leftwards, making the cue appear more to the left compared to an align:middle cue.

To make the default behavior more intuitive (without losing expressiveness with how the two settings can be used together), I suggest that specifying align:start and not specifying position should make position default to 0%, and similarly align:end 100%.
Comment 1 Silvia Pfeiffer 2012-09-12 23:57:23 UTC
Created attachment 1186 [details]
default position when align change

default position when align change
Comment 2 Silvia Pfeiffer 2012-09-12 23:59:01 UTC
I believe the example at the beginning of the spec at http://dev.w3.org/html5/webvtt/#introduction has fallen into this trap. I've rendered the example in the attached image on a random video. I believe the display is not what the author intended.
Comment 3 Simon Pieters 2012-09-13 06:16:11 UTC
Yes, that very clearly illustrates the problem.
Comment 4 Ian 'Hixie' Hickson 2012-11-21 19:51:54 UTC

*** This bug has been marked as a duplicate of bug 20037 ***
Comment 5 Philip J├Ągenstedt 2014-05-11 13:02:15 UTC
This was not fixed by bug 20037 so I am reopening it.
Comment 6 Silvia Pfeiffer 2014-05-12 00:32:41 UTC
The addition of the "default text track cue text position" has addressed this issue a while ago.