Bug 18605 - popstate in traversal: "state changed" should be false if there's no /latest entry/. (it's dodgy to be firing popstate so early since most of the time you won't be able to detect it anyway, and the state can't have changed by then so why bother firing it)
popstate in traversal: "state changed" should be false if there's no /latest ...
Status: RESOLVED FIXED
Product: WHATWG
Classification: Unclassified
Component: HTML
unspecified
Other other
: P3 normal
: Unsorted
Assigned To: Ian 'Hixie' Hickson
contributor
http://www.whatwg.org/specs/web-apps/...
:
: 18405 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 18:28 UTC by contributor
Modified: 2012-09-18 23:09 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2012-08-17 18:28:43 UTC
Specification: http://www.whatwg.org/specs/web-apps/current-work/
Multipage: http://www.whatwg.org/C#history-traversal
Complete: http://www.whatwg.org/c#history-traversal

Comment:
popstate in traversal: "state changed" should be false if there's no /latest
entry/. (it's dodgy to be firing popstate so early since most of the time you
won't be able to detect it anyway, and the state can't have changed by then so
why bother firing it)

Posted from: 216.239.45.4 by ian@hixie.ch
User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.6 Safari/537.4
Comment 1 Ian 'Hixie' Hickson 2012-08-17 18:30:22 UTC
http://krijnhoetmer.nl/irc-logs/whatwg/20120817#l-350
Comment 2 Ian 'Hixie' Hickson 2012-09-18 23:07:31 UTC
*** Bug 18405 has been marked as a duplicate of this bug. ***
Comment 3 contributor 2012-09-18 23:09:06 UTC
Checked in as WHATWG revision r7375.
Check-in comment: Don't fire popstate on initial traversal.
http://html5.org/tools/web-apps-tracker?from=7374&to=7375