Bug 18575 - Section 2. Source Buffer Model should be non-normative
Section 2. Source Buffer Model should be non-normative
Status: RESOLVED FIXED
Product: HTML WG
Classification: Unclassified
Component: Media Source Extensions
unspecified
All All
: P2 normal
: ---
Assigned To: Aaron Colwell (c)
HTML WG Bugzilla archive list
tpac2012
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 13:56 UTC by Philip Jägenstedt
Modified: 2012-12-18 18:58 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Jägenstedt 2012-08-15 13:56:18 UTC
http://dvcs.w3.org/hg/html-media/raw-file/tip/media-source/media-source.html#source-buffer-model

Some of the things mentioned in this section look like normative requirements since the magic words may/should/must appear and there is language like "An exception is thrown if the application tries to update the attribute when only part of a media segment has been appended."

To remove any doubt, the entire section should be marked as non-normative.

(Not hypothetical, I was going to file a bug that it didn't say which exception to throw, before I realized it wasn't intended to be normative.)
Comment 1 Aaron Colwell (c) 2012-08-17 23:29:20 UTC
(In reply to comment #0)
> http://dvcs.w3.org/hg/html-media/raw-file/tip/media-source/media-source.html#source-buffer-model
> 
> Some of the things mentioned in this section look like normative requirements
> since the magic words may/should/must appear and there is language like "An
> exception is thrown if the application tries to update the attribute when only
> part of a media segment has been appended."
> 
> To remove any doubt, the entire section should be marked as non-normative.
> 
> (Not hypothetical, I was going to file a bug that it didn't say which exception
> to throw, before I realized it wasn't intended to be normative.)
Hmm... Many of these sections were intended to convey requirements which is why the musts are in there. Perhaps this means that I should update the algorithm text to make sure these rules are enforced so the 2.x sections aren't necessary? I'd hate for a large part of the spec to become a green box.
Comment 2 Philip Jägenstedt 2012-08-20 09:52:29 UTC
Yes, I think it would be better if all the normative requirements are expressed in the algorithms, and that a high-level overview is explicitly non-normative. As it is now, some requirements are expressed twice and may not align exactly. It's of course possible to interleave the normative and the non-normative, if that would make for better reading.
Comment 3 Adrian Bateman [MSFT] 2012-10-22 01:07:05 UTC
Assigned to Aaron. This represents a large reorganization of the content. Need to make a proposal and then discuss. Added tpac2012 whiteboard tag.
Comment 4 Aaron Colwell (c) 2012-12-18 18:58:13 UTC
I believe most of the redundant and non-normative text has been removed by the following changes.

http://dvcs.w3.org/hg/html-media/rev/e1c91093dfdc
http://dvcs.w3.org/hg/html-media/rev/ee6e8ae9337c
http://dvcs.w3.org/hg/html-media/rev/43be42e69533

Some non-normative text still remains, but it is clearly marked as such. I also believe the various overlap sections, though under specified, now contain normative statements. These sections will include more detail in the future, but I believe they roughly capture the intended behavior that is required for implementation.