The key value for scroll lock is mentioned as both "Scroll" (under 6.2.2) and "ScrollLock" (under 5.2.5 and 22.214.171.124). In practice, Internet Explorer 9 sets the key value to "Scroll".
Fixed in the latest version of the spec: r240
Ugh... Mozilla has changed the key name to "ScrollLock" because the draft had changed the name. And unfortunately the first version which implements getModifierState() has been shipped with "ScrollLock".
Why the name had been changed and back again by this bug??
Re-opening this bug--needs a more detailed investigation, especially now with conflicting implementations and prior spec inconsistency.
"Scroll" isn't clear if I see it in source code. The "ScrollLock" seems better in that point. And there are "CapsLock", "NumLock", "SymbolLock" and "FnLock". So, I wonder why the Scroll Lock key name is "Scroll". I guess it comes from VK_SCROLL which is Windows' virtual keycode. But I don't feel it's good name for the key.
GDK's key name (and might be X's key name too) is GDK_Scroll_Lock.
Fixed (as "ScrollLock") in latest ED.