Bug 18045 - Based on my experience and from reading many questions on the Web, this API is seriously flawed. It treats cross-domain iframes the same as same-domain iframes, except that almost every operation on contentWindow is an error.
Based on my experience and from reading many questions on the Web, this API i...
Status: RESOLVED DUPLICATE of bug 15942
Product: WebAppsWG
Classification: Unclassified
Component: Web Messaging (editor: Ian Hickson)
unspecified
Other other
: P3 normal
: ---
Assigned To: Ian 'Hixie' Hickson
public-webapps-bugzilla
http://www.whatwg.org/specs/web-apps/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 16:07 UTC by contributor
Modified: 2013-01-30 20:32 UTC (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2012-07-18 16:07:21 UTC
This was was cloned from bug 15942 as part of operation convergence.
Originally filed: 2012-02-09 16:28:00 +0000

================================================================================
 #0   contributor@whatwg.org                          2012-02-09 16:28:49 +0000 
--------------------------------------------------------------------------------
Specification: http://www.whatwg.org/specs/web-apps/current-work/multipage/web-messaging.html
Multipage: http://www.whatwg.org/C#introduction-10
Complete: http://www.whatwg.org/c#introduction-10

Comment:
Based on my experience and from reading many questions on the Web, this API is
seriously flawed. It treats cross-domain iframes the same as same-domain
iframes, except that almost every operation on contentWindow is an error.

Posted from: 2620:0:1000:1b01:7aac:c0ff:feb3:65b0
User agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.3 Safari/535.19
================================================================================
Comment 1 Ian 'Hixie' Hickson 2012-10-19 22:26:09 UTC
Can you elaborate?
Comment 2 Ian 'Hixie' Hickson 2013-01-30 20:32:36 UTC

*** This bug has been marked as a duplicate of bug 15942 ***