Bug 17777 - The IDL of WD-webaudio-20120315 is invalid
The IDL of WD-webaudio-20120315 is invalid
Status: CLOSED FIXED
Product: AudioWG
Classification: Unclassified
Component: Web Audio API
unspecified
PC All
: P2 normal
: TBD
Assigned To: Ehsan Akhgari [:ehsan]
public-audio
:
: 17322 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-14 03:47 UTC by Fuji Goro (gfx)
Modified: 2012-09-10 10:18 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fuji Goro (gfx) 2012-07-14 03:47:08 UTC
The IDL of http://www.w3.org/TR/2012/WD-webaudio-20120315/ is invalid in terms of WebIDL.

For example, interface blocks have no semicolon while WebIDL requires it.

Please keep IDL valid to allow us to process them with IDL parsers.

Regards,
--------
gfx
Comment 1 Ehsan Akhgari [:ehsan] 2012-07-19 17:20:26 UTC
Where can I find the source of the spec so that I can submit patches?  I'm working on making the IDL compatible with Web IDL.
Comment 2 Olivier Thereaux 2012-07-19 21:03:56 UTC
(In reply to comment #1)
> Where can I find the source of the spec so that I can submit patches?  I'm
> working on making the IDL compatible with Web IDL.

Here: https://dvcs.w3.org/hg/audio/raw-file/tip/webaudio/specification.html
Comment 3 Olivier Thereaux 2012-08-10 11:47:01 UTC
*** Bug 17322 has been marked as a duplicate of this bug. ***
Comment 4 Ehsan Akhgari [:ehsan] 2012-08-24 19:54:49 UTC
I believe I have fixed all of the problems.  The IDL in the spec should now be valid Web IDL.
Comment 5 Olivier Thereaux 2012-09-10 10:18:50 UTC
Closing, thank you Ehsan for all your work (see http://dvcs.w3.org/hg/audio/log?rev=IDL for a number of changesets applicable to this issue).