Bug 17729 - suggest needKey report codecs+key system supported by the UA
suggest needKey report codecs+key system supported by the UA
Status: RESOLVED WORKSFORME
Product: HTML WG
Classification: Unclassified
Component: Encrypted Media Extensions
unspecified
PC All
: P2 normal
: ---
Assigned To: Adrian Bateman [MSFT]
HTML WG Bugzilla archive list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 03:25 UTC by Yang Sun
Modified: 2012-08-28 20:26 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yang Sun 2012-07-10 03:25:45 UTC
It is a little complex for JS to test the UA using canPlayType() for many times to determine the key system.

I propose we just use needKey event to report the supported codec+key system pairs list to app, let app choose one key system among it, this will reduce the times of call to the UA for testing key system using canPlayType, and avoid extension of canPlayType.

What do you think about it?
Comment 1 Adrian Bateman [MSFT] 2012-07-10 14:02:39 UTC
We considered this before submitting the original proposal. However, we expect the number of possible key systems to be small and so the web page can try generateKeyRequest with different key systems in the order of preference of the site until one matches the [UA,Page,Media] supported combination.
Comment 2 David Dorwin 2012-08-28 20:26:35 UTC
The behavior is by design and consistent with existing canPlayType() use.