Bug 17693 - editorial mode for HTML page
editorial mode for HTML page
Status: RESOLVED DUPLICATE of bug 13057
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec
unspecified
PC All
: P2 normal
: ---
Assigned To: Edward O'Connor
HTML WG Bugzilla archive list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 07:13 UTC by Yang Sun
Modified: 2013-02-12 19:56 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yang Sun 2012-07-05 07:13:59 UTC
Microsoft word document has an editorial mode, we can see who change which part of document at what time. Editorial is very useful for group collaboration of paper and specification.

In other standard organization, every working draft will have 1 dirty edition which is in editorial mode thus we can see the detailed change to the specification, and 1 clean edition which does not include any editorial information.

W3C working draft have no editorial mode, so we can not see the change to the specification and the editorial history to the specification.

Can we add editorial mode to HTML.NEXT,

so we can switch on/off the editorial mode for the specification, we may need some new attribute to the existing element or we can define new element like <new>,<delete> etc.

I think in the future, document will most be in HTML mode due to HTML5's development, so define editorial mode for HTML will aid the web document function.
Google Docs will be an important scenario for usage of editorial mode.

It is really beneficial if HTML.NEXT can include this function.
Comment 1 Robin Berjon 2013-01-21 15:59:27 UTC
Mass move to "HTML WG"
Comment 2 Robin Berjon 2013-01-21 16:02:12 UTC
Mass move to "HTML WG"
Comment 3 Edward O'Connor 2013-02-12 19:56:24 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are
satisfied with this response, please change the state of this bug to CLOSED. If
you have additional information and would like the Editor to reconsider, please
reopen this bug. If you would like to escalate the issue to the full HTML
Working Group, please add the TrackerRequest keyword to this bug, and suggest
title and text for the Tracker Issue; or you may create a Tracker Issue
yourself, if you are able to do so. For more details, see this document:

   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: No spec change.
Rationale: Duplicate of bug 13057.

*** This bug has been marked as a duplicate of bug 13057 ***