Current draft defines "ExSel" key. However, IE9 uses "Exsel" (the "s" is lowercase). And also, "Crsel" in the draft uses lower "s" too. So, I think that it should be "Exsel".
Looking into this...
This change is good for consistency with Crsel, and also to align with a shipping implementation. Good catch.
Case is fixed in the latest draft. Please review and close the bug.
The correct name for these keys is ExSel and CrSel since they are abbreviations and the naming convention is to use InitialCaps for key names.
Microsoft* and USB** documents also refer to these keys using InitialCaps.
So 'ExSel' in the original draft was correct.
I'm not sure your suggestion is worthwhile.
1. IE already uses the not good names already.
2. Firefox 23 will use same names if the spec isn't changed as soon as possible.
3. WebKit and Blink don't support .key yet.
However, key events for the keys are typically not fired because usual keyboard doesn't have the keys, though.
As someone said on the mailing list, D3E is still a "Working Draft" and we're hoping to use implementations to identify and fix problems with the spec, not to fossilize them.
I agree that we should fix these names as soon as possible.
Fixed in ED by using 'ExSel' and 'CrSel', which are the correct names for these keys based on USB and Microsoft documentation.