Bug 17570 - Function declaration of Node::lookupPrefix and Node::lookupNamespaceURI do not allow 'null' return value
Summary: Function declaration of Node::lookupPrefix and Node::lookupNamespaceURI do no...
Status: RESOLVED FIXED
Alias: None
Product: WebAppsWG
Classification: Unclassified
Component: DOM (show other bugs)
Version: unspecified
Hardware: PC Windows NT
: P2 normal
Target Milestone: ---
Assignee: Anne
QA Contact: public-webapps-bugzilla
URL:
Whiteboard:
Keywords:
: 17881 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-22 01:46 UTC by svitlant
Modified: 2012-09-11 19:22 UTC (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description svitlant 2012-06-22 01:46:59 UTC
Implementation details of Node::lookupPrefix (http://dvcs.w3.org/hg/domcore/raw-file/tip/Overview.html#dom-node-lookupprefix) and Node::lookupNamespaceURI (http://dvcs.w3.org/hg/domcore/raw-file/tip/Overview.html#dom-node-lookupnamespaceuri) functions indicate that the value 'null' can be returned. However, the declaration of those functions in Node interface (http://dvcs.w3.org/hg/domcore/raw-file/tip/Overview.html#node) does not have a question mark ('?') next to the return type of those functions.
Comment 1 contributor 2012-07-18 07:11:23 UTC
This bug was cloned to create bug 17881 as part of operation convergence.
Comment 2 Anne 2012-08-27 08:45:16 UTC
*** Bug 17881 has been marked as a duplicate of this bug. ***
Comment 3 Anne 2012-09-11 15:00:32 UTC
https://github.com/WHATWG/dom/commit/d8e02a7096e3bba81693116a3912f82371523cec

Could you please give your name for the acknowledgments? If you do not want to be listed, just close this bug I suppose.
Comment 4 svitlant 2012-09-11 19:22:56 UTC
Thank you very much for following up on this bug, Anne.