Bug 17556 - HTML should define EventHandler so other specs can use it
Summary: HTML should define EventHandler so other specs can use it
Status: RESOLVED DUPLICATE of bug 15358
Alias: None
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal
Target Milestone: ---
Assignee: Ian 'Hixie' Hickson
QA Contact: HTML WG Bugzilla archive list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-20 09:11 UTC by Marcos Caceres
Modified: 2012-06-20 09:23 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcos Caceres 2012-06-20 09:11:10 UTC
In [1] Cam suggested that the following be added to DOM4 - so that authors could just use EventHandler instead of [TreatNonCallableAsNull] everywhere:

  [TreatNonCallableAsNull] callback EventHandler = void (Event event);

But in [2], Anne said that it was to be defined in HTML. 

[1] http://lists.w3.org/Archives/Public/www-dom/2012AprJun/0163.html
[2] http://lists.w3.org/Archives/Public/www-dom/2012AprJun/0165.html
Comment 1 Anne 2012-06-20 09:23:19 UTC

*** This bug has been marked as a duplicate of bug 15358 ***