Bug 16978 - i18n-ISSUE-118: explicitly undefined language
Summary: i18n-ISSUE-118: explicitly undefined language
Status: RESOLVED DUPLICATE of bug 17864
Alias: None
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec (show other bugs)
Version: unspecified
Hardware: PC Windows NT
: P3 editorial
Target Milestone: ---
Assignee: Robin Berjon
QA Contact: HTML WG Bugzilla archive list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-07 18:06 UTC by Addison Phillips
Modified: 2015-06-17 02:58 UTC (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Addison Phillips 2012-05-07 18:06:51 UTC
3.2.3.3 The lang and xml:lang attributes
http://www.w3.org/TR/html5/elements.html#the-lang-and-xml:lang-attributes

(lang). What does this mean:

--
If the resulting value is the empty string, then it must be interpreted as meaning that the language of the node is explicitly unknown.
--

Does an explicitly unknown language have any different effect? It might be a good idea to add text such as:

--
If the resulting value is the empty string, then it must be interpreted as meaning that the language of the node is explicitly unknown and any language specific processing that applied is implementation defined.
--
Comment 1 Ian 'Hixie' Hickson 2012-05-10 17:55:59 UTC
I believe this is a duplicate of a previously existing bug with more discussion.
Comment 2 contributor 2012-07-18 07:08:26 UTC
This bug was cloned to create bug 17864 as part of operation convergence.
Comment 3 Michael[tm] Smith 2015-06-17 02:58:03 UTC
(In reply to Ian 'Hixie' Hickson from comment #1)
> I believe this is a duplicate of a previously existing bug with more
> discussion.

Agreed. So, closing this one.

*** This bug has been marked as a duplicate of bug 17864 ***