Bug 16834 - FileList in input.files (multiple attribute)
Summary: FileList in input.files (multiple attribute)
Status: RESOLVED DUPLICATE of bug 17125
Alias: None
Product: WebAppsWG
Classification: Unclassified
Component: File API (show other bugs)
Version: unspecified
Hardware: All All
: P2 enhancement
Target Milestone: ---
Assignee: Arun
QA Contact: public-webapps-bugzilla
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-24 10:26 UTC by krossekrabbe
Modified: 2013-03-13 18:52 UTC (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description krossekrabbe 2012-04-24 10:26:54 UTC
I hope I'm submitting this feature request to the correct place, not quite sure.

--

Accessing the files attribute of an input element returns the files as FileList object, which is - AFAIK - part of the FileSystem API and therefore grants only read-only access to its contents.

Unfortunately there are several common use cases which would require the ability to programmatically _remove_ particular files from the FileList, which seems not to be possible currently.

For example:

a) Checking the file.size for some limit before uploading, if limit is exceeded exclude the particular file from uploading.

b) Giving the end-user an opportunity of reviewing his file selection and to exclude accidentally selected files.

Here's the discussion of a guy facing the same problem:
http://stackoverflow.com/questions/3144419/how-do-i-remove-a-file-from-the-filelist
Comment 1 Robin Berjon 2013-01-21 15:57:55 UTC
Mass move to "HTML WG"
Comment 2 Robin Berjon 2013-01-21 16:00:38 UTC
Mass move to "HTML WG"
Comment 3 Robin Berjon 2013-03-11 15:32:09 UTC
This is not something for the HTML specification to change, FileList is defined by the File API specification (http://dev.w3.org/2006/webapi/FileAPI/#dfn-filelist).

But don't worry — I'm moving your bug there so that it can be processed by the right people, this is a good bug.
Comment 4 Arun 2013-03-11 17:06:39 UTC
This bug is a likely dupe of Bug 17125.
Comment 5 Arun 2013-03-13 18:52:40 UTC
Marking dupe.  Let's continue discussion in Bug 17125

*** This bug has been marked as a duplicate of bug 17125 ***