Bug 16833 - consider always exposing a "length" property for objects with indexed properties
Summary: consider always exposing a "length" property for objects with indexed properties
Status: RESOLVED WONTFIX
Alias: None
Product: WebAppsWG
Classification: Unclassified
Component: WebIDL (show other bugs)
Version: unspecified
Hardware: PC Windows 3.1
: P2 normal
Target Milestone: ---
Assignee: Cameron McCormack
QA Contact: public-webapps-bugzilla
URL:
Whiteboard:
Keywords:
: 20561 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-24 08:23 UTC by Cameron McCormack
Modified: 2013-08-04 06:51 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cameron McCormack 2012-04-24 08:23:49 UTC
Rather than relying on spec authors to add a

  readonly attribute unsigned long length;

to an interface that has an index getter, it would be simpler to have all such objects/interfaces expose a length property.
Comment 1 Marcos Caceres 2013-01-22 12:50:17 UTC
We've been sitting on this one for a long time. Would be good to make a decision on this.
Comment 2 Cameron McCormack 2013-06-17 01:18:01 UTC
Not going to do this for now.  That specs need to include a "length" IDL attribute isn't particularly problematic.
Comment 3 Cameron McCormack 2013-08-04 06:51:51 UTC
*** Bug 20561 has been marked as a duplicate of this bug. ***