Bug 16709 - Update HTML for Fullscreen
Update HTML for Fullscreen
Status: RESOLVED FIXED
Product: HTML.next
Classification: Unclassified
Component: default
unspecified
PC All
: P2 critical
: ---
Assigned To: Silvia Pfeiffer
HTML WG Bugzilla archive list
http://dvcs.w3.org/hg/fullscreen/raw-...
:
: 16452 (view as bug list)
Depends on: 18840
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 07:35 UTC by Anne
Modified: 2012-12-07 11:01 UTC (History)
10 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anne 2012-04-12 07:35:41 UTC
As discussed on the WHATWG list and elsewhere, HTML needs a few updates to make Fullscreen "work" (and better):

* Define that the "fullscreen enabled flag" is set for top-level browsing contexts.
* Define that the "fullscreen enabled flag" is set for nested browsing contexts if their browsing context container (including ancestors) has a allowfullscreen="" attribute set. (That attribute needs to be defined too.)
* "fully exit fullscreen" when navigating.
* onfullscreenchange and onfullscreenerror event handlers
Comment 1 Anne 2012-04-12 07:36:04 UTC
*** Bug 16452 has been marked as a duplicate of this bug. ***
Comment 2 Anne 2012-04-12 07:38:13 UTC
Hixie, I'm setting this to critical so browsers can start removing the silly prefixes sooner.
Comment 3 contributor 2012-07-18 07:00:00 UTC
This bug was cloned to create bug 17838 as part of operation convergence.
Comment 4 Edward O'Connor 2012-10-16 21:04:07 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are
satisfied with this response, please change the state of this bug to CLOSED. If
you have additional information and would like the Editor to reconsider, please
reopen this bug. If you would like to escalate the issue to the full HTML
Working Group, please add the TrackerRequest keyword to this bug, and suggest
title and text for the Tracker Issue; or you may create a Tracker Issue
yourself, if you are able to do so. For more details, see this document:

   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: No spec change.
Rationale: Let's address this in HTML.next.
Comment 5 Silvia Pfeiffer 2012-12-07 11:01:33 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If
you are satisfied with this response, please change the state of
this bug to CLOSED. If you have additional information and would
like the Editor to reconsider, please reopen this bug. If you would
like to escalate the issue to the full HTML Working Group, please
add the TrackerRequest keyword to this bug, and suggest title and
text for the Tracker Issue; or you may create a Tracker Issue
yourself, if you are able to do so. For more details, see this
document:   http://dev.w3.org/html5/decision-policy/decision-policy-v2.html

Status: Accepted

Change Description:
https://github.com/w3c/html/commit/f944338c35275a6ef39f1f74a51a6423a77fccfd

Rationale: Adopted WHATWG spec patch for HTML5.1