Bug 16490 - Add [ArrayClass] to HTMLCollection?
Add [ArrayClass] to HTMLCollection?
Status: RESOLVED WONTFIX
Product: WebAppsWG
Classification: Unclassified
Component: DOM
unspecified
PC All
: P2 normal
: ---
Assigned To: Anne
public-webapps-bugzilla
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-23 08:05 UTC by Anne
Modified: 2012-11-05 19:52 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anne 2012-03-23 08:05:55 UTC
NodeList is annotated with [ArrayClass] at the moment, can we annotate HTMLCollection with it as well?

The problem is its named getter, but maybe there is some workaround for that?
Comment 1 Cameron McCormack 2012-03-24 00:39:40 UTC
Yeah, I don't think we should do this unless we find a solution to the problem of the Array.prototype function names clashing with named properties on the collection.
Comment 2 Anne 2012-05-15 10:56:05 UTC
I also heard that adding this to NodeList might not work out :-(