Bug 16453 - Rename "node document"
Summary: Rename "node document"
Status: RESOLVED WONTFIX
Alias: None
Product: WebAppsWG
Classification: Unclassified
Component: DOM (show other bugs)
Version: unspecified
Hardware: PC All
: P2 enhancement
Target Milestone: ---
Assignee: Anne
QA Contact: public-webapps-bugzilla
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-20 17:31 UTC by Simon Pieters
Modified: 2012-03-20 20:14 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Pieters 2012-03-20 17:31:40 UTC
I think the name "node document" is confusing. It would be easier to read various specs that use it if it was instead called "owner document".
Comment 1 Boris Zbarsky 2012-03-20 18:09:47 UTC
I think the problem is that node.ownerDocument is null when node is a Document, but the uses that call it "node document" want node itself when node is a Document, right?

Maybe we should just add a realOwnerDocument property that does the sane thing for a Document of returning that same Document?  ;)
Comment 2 Simon Pieters 2012-03-20 18:25:01 UTC
(In reply to comment #1)
> I think the problem is that node.ownerDocument is null when node is a Document,
> but the uses that call it "node document" want node itself when node is a
> Document, right?

I don't see why that's a problem (and it's not the reason it's currently called "node document").

> Maybe we should just add a realOwnerDocument property that does the sane thing
> for a Document of returning that same Document?  ;)

Not without a use case. :-)
Comment 3 Boris Zbarsky 2012-03-20 18:28:04 UTC
> I don't see why that's a problem 

Because having "owner document" mean something different from .ownerDocument seems really confusing to me...
Comment 4 Ms2ger 2012-03-20 20:07:12 UTC
What bz said
Comment 5 Anne 2012-03-20 20:14:36 UTC
Oh yeah, I forgot about that. Consider that reason #2 Simon. :-) The other was consistency with "XMLHttpRequest document".