The spec reads:
"Let class be a string whose value is determined as follows:"
Using the word "class" makes it annoying during implementation, because class is reserved in many languages (hence I can't "var class = "). Please change it to <var>classType</var> or some such. This makes it easier to implement makes the spec and implementation consistant.
There is no requirement that algorithms be implemented as is, especially since they are pseudocode and not actual code. I don't think it's worth changing this -- I had wondered at some point whether I would change my variable names to be possible space separated words, as the HTML spec uses, since that should make some things more readable. You would have even more of a problem, then. :)