Bug 16306 - 'timeout' event defined but never fired
'timeout' event defined but never fired
Status: CLOSED WORKSFORME
Product: WebAppsWG
Classification: Unclassified
Component: XHR
unspecified
PC All
: P2 normal
: ---
Assigned To: Anne
public-webapps-bugzilla
http://dvcs.w3.org/hg/xhr/raw-file/8d...
:
: 16305 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 09:43 UTC by Glenn Adams
Modified: 2012-03-11 19:23 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Glenn Adams 2012-03-10 09:43:19 UTC
nowhere in the specification is there language stating that a timeout event is fired (or at least I couldn't find it)
Comment 1 Odin Hørthe Omdal 2012-03-10 10:06:40 UTC
It is in fact defined: http://dvcs.w3.org/hg/xhr/raw-file/8d4e9ccfdbd4/Overview.html#timeout-error
---

When something is said to be an timeout error run the request error steps for exception "TimeoutError" and event timeout.

When something is said to be a request error for exception exception and event event run these steps:

[...]

9. Fire a progress event named event.
Comment 2 Glenn Adams 2012-03-10 19:03:12 UTC
(In reply to comment #1)
> It is in fact defined:
> http://dvcs.w3.org/hg/xhr/raw-file/8d4e9ccfdbd4/Overview.html#timeout-error
> ---
> 
> When something is said to be an timeout error run the request error steps for
> exception "TimeoutError" and event timeout.
> 
> When something is said to be a request error for exception exception and event
> event run these steps:
> 
> [...]
> 
> 9. Fire a progress event named event.

thanks for pointing that out; however, I see this does not use the formulaic language that is used in other event firing cases; namely, one of:

(1) fire an event named X
(2) fire a progress event named X

for consistency, I would suggest changing the text to use one of the above forms
Comment 3 Anne 2012-03-11 17:04:20 UTC
It does use that.
Comment 4 Anne 2012-03-11 17:04:58 UTC
*** Bug 16305 has been marked as a duplicate of this bug. ***
Comment 5 Glenn Adams 2012-03-11 19:23:41 UTC
ok, i see now it is parameterized via <em>event</em> variable in the "request error" sub-steps