Bug 16167 - i18n-ISSUE-141: Mistake in entity assignments
i18n-ISSUE-141: Mistake in entity assignments
Status: CLOSED INVALID
Product: HTML WG
Classification: Unclassified
Component: HTML5 spec
unspecified
PC All
: P3 normal
: ---
Assigned To: Ian 'Hixie' Hickson
HTML WG Bugzilla archive list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 20:00 UTC by I18n Core WG
Modified: 2014-03-06 23:22 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description I18n Core WG 2012-02-29 20:00:20 UTC
8.5 Named character references
http://www.w3.org/TR/2011/WD-html5-20110525/named-character-references.html#named-character-references

WG Approved: Yes

This is via Yasin Hınıslıoğlu, who writes about character assignments for ⟨ and ⟩...

[[
In the html 4 specification, which is here: http://www.w3.org/TR/REC-html40/sgml/entities.html above values declared are as follow,
&rang: u+2329 utf8: E2 8C AA
&lang: u+232A utf8: E2 8C A9

Contrary in html 5 specification, which is here: http://www.w3.org/TR/html5/named-character-references.html, same named entities are declared as below
⟩ U+027E9
&lang: U+027E8

I checked whole character set defined in html 5 and only these two are different.
]]

Please correct these assignments.
Comment 1 Leif Halvard Silli 2012-03-01 16:31:17 UTC
(In reply to comment #0)

This is not a bug. 

The change is deliberate, and in tune with the W3C Recommendation: "XML Entity Definitions for Characters" See: http://www.w3.org/TR/2010/REC-xml-entity-names-20100401/#diff-xhtml1

Please close the bug.
Comment 2 I18n Core WG 2012-03-01 17:24:16 UTC
Thanks for the clarification.
Comment 3 Addison Phillips 2014-03-06 23:22:32 UTC
Closing. I18N is satisfied that this is invalid.