Bug 15495 - Update EventSource model to do automatic reconnect even in the face of network errors
Update EventSource model to do automatic reconnect even in the face of networ...
Status: RESOLVED FIXED
Product: WebAppsWG
Classification: Unclassified
Component: Server-Sent Events (editor: Ian Hickson)
unspecified
Other other
: P3 blocker
: ---
Assigned To: Ian 'Hixie' Hickson
public-webapps-bugzilla
http://www.whatwg.org/specs/web-apps/...
:
: 18320 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-10 16:17 UTC by contributor
Modified: 2012-10-10 23:03 UTC (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2012-01-10 16:17:45 UTC
Specification: http://www.w3.org/TR/eventsource/
Multipage: http://www.whatwg.org/C#top
Complete: http://www.whatwg.org/c#top

Comment:
I need some way of recovering from longer but still temporary failures,
without requiring a complete page refresh, and without requiring every all
events of interest to be rebound, or otherwise handled differently from any
other event.

This isn't an issue with the WebSocket and XMLHttpRequest API's, as those
interfaces already require one to implement an event passing scheme on top,
making it trivial to replace the underlying WebSocket or XMLHttpRequest. 
While such a scheme could also be implemented on top of EventSource, it seems
silly to stack	an different event source scheme on top of something called
"EventSource".

Posted from: 70.64.129.37
User agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Ubuntu/10.04 Chromium/15.0.874.106 Chrome/15.0.874.106 Safari/535.2
Comment 1 Ian 'Hixie' Hickson 2012-07-10 20:00:23 UTC
The design assumes that when there is a network problem, the script will create a new object. This doesn't seem particularly burdensome...
Comment 2 Ian 'Hixie' Hickson 2012-07-25 02:50:20 UTC
People have suggested we change the model here, so I'll have a look to see how to do that.
Comment 3 Ian 'Hixie' Hickson 2012-08-07 18:03:12 UTC
*** Bug 18320 has been marked as a duplicate of this bug. ***
Comment 4 contributor 2012-10-10 23:03:38 UTC
Checked in as WHATWG revision r7450.
Check-in comment: Change EventSource so that it retries the connection in case of certain 5xx errors and in case of DNS errors or failed connections at the TCP level
http://html5.org/tools/web-apps-tracker?from=7449&to=7450