Bug 14236 - [XPath30] editorial: 3.1.7: "function declaration"
Summary: [XPath30] editorial: 3.1.7: "function declaration"
Status: CLOSED FIXED
Alias: None
Product: XPath / XQuery / XSLT
Classification: Unclassified
Component: XPath 3.0 (show other bugs)
Version: Working drafts
Hardware: All Linux
: P2 minor
Target Milestone: ---
Assignee: Jonathan Robie
QA Contact: Mailing list for public feedback on specs from XSL and XML Query WGs
URL:
Whiteboard:
Keywords:
: 14365 15071 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-22 05:56 UTC by Michael Dyck
Modified: 2013-11-05 00:30 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Dyck 2011-09-22 05:56:31 UTC
In XPath30 and XQuery30 section 3.1.7 "Inline Functions",
there are 3 references to "a function declaration".
Change each to "an inline function expression".

Similarly, in Appendix F "Error Conditions", the blurb for err:XQST0039 says:
    It is a static error for a function declaration to have
    more than one parameter with the same name.

In the XPath spec, "a function declaration" should be "an inline function expression".
In the XQuery spec, it should be "a function declaration or inline function expression".
Comment 1 Jonathan Robie 2011-11-18 23:13:23 UTC
*** Bug 14365 has been marked as a duplicate of this bug. ***
Comment 2 Jonathan Robie 2011-11-19 01:16:13 UTC
Nice catch. The fix will show up in the next build.
Comment 3 Michael Dyck 2011-11-22 06:41:34 UTC
Re 3.1.7:

XPath now says
    a inline function expression
(should be "an").

XQuery says:
    a function declaration or inline function expression
which is true, but the mention of function declaration is unnecessary here. Section 4.18 already states these rules for function declarations.

---

Re Appendix F:
There's been no change.
Comment 4 Jonathan Robie 2011-12-10 19:48:48 UTC
*** Bug 15071 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Robie 2011-12-11 15:07:44 UTC
Fixed now.
Comment 6 Michael Dyck 2011-12-13 18:30:18 UTC
Section 3.1.7 has been fixed. However...

In appendix F, you changed
    a function declaration
to
    an inline function expression

but the error covers both constructs, so you need to change it to:
    <phrase role="xquery">a function declaration or</phrase>
    an inline function expression

or even something like:
    <phrase role="xquery">a function declaration or</phrase>
    <phrase diff="add>an inline function expression</phrase>
(Strictly speaking, the "or" should be part of the diff-add,
but capturing that gets messy.)
Comment 7 Jonathan Robie 2012-10-05 21:57:27 UTC
I believe this is fixed now:

err:XQST0039

It is a static error for an inline function expression to have more than one parameter with the same name.
Comment 8 Michael Dyck 2012-10-09 07:42:22 UTC
The Appendix F blurb for err:XQST0039 has not changed since comment 5.
Therefore, comment 6 still applies.
Comment 9 Jonathan Robie 2013-10-19 17:45:49 UTC
Fixed in source. Will show in next HTML build.
Comment 10 Michael Dyck 2013-11-05 00:30:38 UTC
Yup. (Fourth time's the charm.)