Bug 13786 - Drop the charset parameter or made it non-conforming. Other MIME types introduced by this specification do not allow the charset parameter.
Summary: Drop the charset parameter or made it non-conforming. Other MIME types intro...
Status: RESOLVED FIXED
Alias: None
Product: WebAppsWG
Classification: Unclassified
Component: Server-Sent Events (editor: Ian Hickson) (show other bugs)
Version: unspecified
Hardware: Other other
: P3 normal
Target Milestone: ---
Assignee: Ian 'Hixie' Hickson
QA Contact: public-webapps-bugzilla
URL: http://www.whatwg.org/specs/web-apps/...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-15 14:44 UTC by contributor
Modified: 2011-12-07 18:26 UTC (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description contributor 2011-08-15 14:44:28 UTC
Specification: http://www.whatwg.org/specs/web-apps/current-work/complete.html
Multipage: http://www.whatwg.org/C#text/event-stream
Complete: http://www.whatwg.org/c#text/event-stream

Comment:
Drop the charset parameter or made it non-conforming.  Other MIME types
introduced by this specification do not allow the charset parameter.

Posted from: 113.197.157.202
User agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/13.0.782.107 Safari/535.1
Comment 1 Anne 2011-08-15 15:39:28 UTC
Yeah, the processing rules for unknown parameters just need to be changed. Instead of aborting the request they should simply be ignored, as is the case for unknown parameters with text/html, text/css, etc.
Comment 2 Ian 'Hixie' Hickson 2011-08-23 00:05:35 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: no spec change
Rationale: The problem is that a number of servers actually send charset="" parameters, so we have to support it. We can't ignore it because if the character encoding is set to something else then we would be corrupting the data if we interpreted it as UTF-8. (What if one day we all move on to some new encoding scheme? It's important that we be able to migrate. We can't easily do so if we are ignoring charset=""!)
Comment 3 Anne 2011-08-23 08:00:55 UTC
If we are moving to a new encoding schema that would be problematic for HTML, CSS, etc. resources too. I think it would be better if it is problematic in the same way.
Comment 4 Ian 'Hixie' Hickson 2011-09-04 03:30:45 UTC
How would it be problematic for HTML and CSS? They actually support charset="", so a new type wouldn't be a problem at all as far as I can tell.
Comment 5 Anne 2011-09-04 07:15:23 UTC
HTML and CSS have a fallback encoding too (typically Windows-1252 or some locale-specific encoding). The resource does not become unsupported. Here the fallback would just be fixed to UTF-8.
Comment 6 Anne 2011-09-04 07:16:13 UTC
And to be clear, UTF-8 would remain to be the only encoding that works until we decide otherwise.
Comment 7 Ian 'Hixie' Hickson 2011-09-04 21:21:59 UTC
I don't really see why we'd actively ignore charset="" here.
Comment 8 Anne 2011-09-04 21:25:52 UTC
Because for MIME types in general you always ignore unknown parameters. That is, you do not halt processing. And if charset is a recognized parameter it should not behave differently from HTML when confronted with an unknown value.
Comment 9 Ian 'Hixie' Hickson 2011-10-18 20:28:48 UTC
(In reply to comment #8)
> Because for MIME types in general you always ignore unknown parameters. That
> is, you do not halt processing.

But it isn't unknown.

> And if charset is a recognized parameter it
> should not behave differently from HTML when confronted with an unknown value.

I don't see why. HTML does all kinds of crazy stuff we shouldn't copy.
Comment 10 Anne 2011-10-19 01:28:03 UTC
It is not just text/html. Every other MIME type that takes a charset parameter behaves this way, text/css, text/javascript.
Comment 11 Ian 'Hixie' Hickson 2011-10-25 00:11:21 UTC
Are you arguing those are any less crazy? :-)
Comment 12 Ian 'Hixie' Hickson 2011-10-26 23:33:31 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: no spec change
Rationale: I see no value in silently ignoring the charset="" parameter. We don't ignore any other parameter, why ignore this one? We only support it at all because some servers insist on sending it, according to implementation feedback.
Comment 13 Anne 2011-11-02 14:18:37 UTC
We should ignore the other parameters too.  Name one format that is similar to text/event-stream.
Comment 14 Ian 'Hixie' Hickson 2011-11-02 17:03:28 UTC
Ah, if you want to ignore all parameters that's a different matter.
Comment 15 Ian 'Hixie' Hickson 2011-12-07 18:26:34 UTC
Done.