This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 13416 - [editing] Rename or restructure the contenteditable="" section so that the relevance of designMode is also apparent in the table of contents
Summary: [editing] Rename or restructure the contenteditable="" section so that the re...
Alias: None
Product: HTML WG
Classification: Unclassified
Component: LC1 HTML5 spec (show other bugs)
Version: unspecified
Hardware: Other other
: P2 normal
Target Milestone: ---
Assignee: Rich Schwerdtfeger
QA Contact: HTML WG Bugzilla archive list
URL: a11ytf
Keywords: a11y
: 13143 (view as bug list)
Depends on:
Reported: 2011-07-28 16:57 UTC by Rich Schwerdtfeger
Modified: 2011-11-15 11:29 UTC (History)
9 users (show)

See Also:


Description Rich Schwerdtfeger 2011-07-28 16:57:17 UTC
Section 7.5 should be renamed "editing host" or something like that as the name implies the section only applies to the contenteditable attribute. The section should be reworked.

    Where it becomes confusing is designMode. designMode places the entire document in an editing mode and should also be considered an editing host.
    DesignMode (section 7.5.2) is a subsection of 7.5, the contenteditable attribute. Yet, 7.5.1 defines User Editing Actions. It is not clear that User Editing Actions apply to both contenteditable and designMode. I think we agree that it should and it is intended but that is now how section 7.5 is structured. Where this becomes important is that 7.5.1 describes the user functions apply to an editing section. This is important for main stream clarification and for accessibility to ensure access to Editing Hosts. These also need to apply to designMode. Fortunately, the user functions (move the caret, etc.) are defined in a device independent way. 7.5 should be restructured as follows: 

7.5 Editing hosts

Introductory text should state that this applies to elements having contentEditable in the true state and design Mode in the enabled state.

7.5.1 contentEditable 7.5.2 designMode 7.5.3 User Editing Actions for Editing Hosts

Another approach could be to state that designMode="on" means the equivalent of "contentEditable" being true as applied to the entire document. 

Where this becomes an accessibility problem is that people with disabilities need consistency among editable sections of the document.
Comment 1 Aryeh Gregor 2011-07-28 18:37:54 UTC
I agree that "The contenteditable attribute" isn't a good name.  I suggest a name like "Editable content: contenteditable and designMode" or something, so that the keywords "contenteditable" and "designMode" will appear in the TOC and can be easily found with Ctrl-F on the multipage spec.  Currently contenteditable appears and designMode doesn't.

Alternatively, rename the section "Editable content and editing hosts", then define two subsections "The contenteditable attribute" and "designMode: making entire documents editable" or something.

Bug 13423, bug 13424, bug 13425 are relevant, but don't really conflict with this bug.
Comment 2 Michael[tm] Smith 2011-08-04 05:03:12 UTC
mass-moved component to LC1
Comment 3 Rich Schwerdtfeger 2011-08-09 20:07:29 UTC
Something along those lines (naming) would be fine. This will require some restructuring of the section so that you now have a contenteditable attribute and designmode attribute, etc.
Comment 4 Anne 2011-08-16 09:14:37 UTC
*** Bug 13143 has been marked as a duplicate of this bug. ***
Comment 5 Ian 'Hixie' Hickson 2011-08-25 23:40:32 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:

Status: Partially Accepted
Change Description: I did something like what is suggested in comment 1.
Rationale: The previous naming scheme was inconsistent and confusing.

I'll probably tweak this further in the coming hours.
Comment 6 Rich Schwerdtfeger 2011-08-26 13:05:24 UTC
thank you Ian
Comment 7 Marco Ranon 2011-11-15 11:29:29 UTC
Rich, can you close the bug if you are happy with the changes? Otherwise can you indicate if this should be a Task Force priority? Thanks (in behalf of the a11y bug triage sub-team).