This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 13101 - TAG issue on HTML+RDFa and Microdata last call drafts
Summary: TAG issue on HTML+RDFa and Microdata last call drafts
Status: RESOLVED NEEDSINFO
Alias: None
Product: HTML WG
Classification: Unclassified
Component: LC1 HTML+RDFa (editor: Manu Sporny) (show other bugs)
Version: unspecified
Hardware: Other All
: P1 normal
Target Milestone: ---
Assignee: Manu Sporny
QA Contact: HTML WG Bugzilla archive list
URL: http://www.w3.org/mid/4E04A795.502060...
Whiteboard:
Keywords:
Depends on: 13100
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-30 16:35 UTC by Michael[tm] Smith
Modified: 2011-10-11 18:07 UTC (History)
17 users (show)

See Also:


Attachments

Description Michael[tm] Smith 2011-06-30 16:35:06 UTC
+++ This bug was initially created as a clone of Bug #13100 +++

public-html-comments posting from: Noah Mendelsohn <nrm@arcanedomain.com>
http://www.w3.org/mid/4E04A795.5020609@arcanedomain.com

SUMMARY

Arising from its Last Call review of the HTML5 suite of specifications, the 
TAG wishes to raise issues on both the HTML microdata [1] and HTML+RDFa 1.1 
[2] Working Drafts.

Specifically, our opinion is that the W3C should not publish two 
specifications that meet such similar requirements in incompatible ways. We 
think doing so would cause confusion for users and implementers, promote 
lock-in, and fragment the web. We request that the W3C Director set up a 
task force to find agreement on a way forward.

DETAIL

The RDF data generated by microdata and RDFa processors is different both 
for documents containing no additional data markup and for documents that 
contain RDFa. This incompatibility might possibly be remedied by removing 
the relevant sections from the microdata specification, but there are 
deeper problems that arise from the fact that the two technologies do much 
the same thing in different ways. Users find it hard to choose which to 
use. It is hard for users to move between them because they are outwardly 
very similar but have differences in parsing algorithms that are not 
immediately obvious. From a publisher's point of view, using both within a 
document leads to repetition; using only one means locking yourself into a 
particular technology stack and set of consumers. Similarly, from an 
implementer or consumer's point of view, implementing both increases code 
quantity and complexity, but implementing only one excludes potential 
customers or data providers.

Both specifications come from a community interested in publishing and 
consuming structured data within Web pages. The TAG's purpose here is not 
to comment on the relative merits of the technologies, nor to signal 
whether one or the other might have preferred status due to history of 
deployment. Rather, we are raising the issue that the W3C has before it two 
Last Call Working Drafts specifying capabilities that overlap and that will 
cause incompatibilities if deployed together. It would be irresponsible for 
the TAG not to attempt to help the community to reconcile the two 
specifications.

We therefore suggest that W3C create a task force of people who are 
knowledgeable about publishing, processing and consuming structured data, 
including those invested in microdata, RDFa and microformats, to provide 
input and focus to the HTML WG in aligning the two specifications. We 
suggest the task force investigate options including, but not limited to:

   * combining RDFa and microdata into a single language with two 
conformance levels, with consistent processing between the two that enable 
advanced users to use more complex features that are recognised by advanced 
processors, without rendering their data invisible to simpler processors

   * combining RDFa and microdata into a single language that is a middle 
ground between the two technologies

   * retaining both microdata and RDFa as separate syntaxes, but ensuring 
that there is a clear story that enables users and implementers to choose 
which to use or implement, that both can be used within the same document 
without incompatibility in the RDF that is generated from them, that as 
much code as possible can be reused in their implementation, and that users 
can easily transition between the two syntaxes

The task force should be tasked to strive towards compatibility with other 
W3C specifications, particularly HTML5. It should also take into 
consideration other existing specifications, and impacts on existing user 
and implementer communities.

Thank you very much.

Noah Mendelsohn
for the W3C Technical Architecture Group

[1]: http://www.w3.org/TR/2011/WD-microdata-20110525/
[2]: http://www.w3.org/TR/2011/WD-rdfa-in-html-20110525/
Comment 1 Manu Sporny 2011-07-01 03:54:40 UTC
The bug is accepted, there was a discussion about this during the RDF Web Apps telecon today, more information on the RDFa WG's position can be found here:

http://www.w3.org/2010/02/rdfa/meetings/2011-06-30#Official_Position_on_WWW__2d_TAG_issue

The RDF Web Apps WG will have an official response to the TAG within a week. I'm assuming that the resolution of this bug will depend on the creation and proper execution of the Task Force described by the TAG in their comment.
Comment 2 Paul Cotton 2011-07-05 18:13:33 UTC
The HTML WG discussed this item at our Jun 30 weekly distributed meeting.  See:
http://www.w3.org/2011/06/30-html-wg-minutes.html#item09 

/paulc
Comment 3 Paul Cotton 2011-07-05 18:22:24 UTC
(In reply to comment #1)

> I'm assuming that the resolution of this bug will depend on the creation and
> proper execution of the Task Force described by the TAG in their comment.

That is a risky assumption given that the Last Call ends on Aug 4 which is less than one month away and the TF has not yet been created.

I encourage you to provide specific more actionable changes that can be made as Last Call comments ASAP.

/paulc
Comment 4 Manu Sporny 2011-07-05 19:51:26 UTC
(In reply to comment #3)
> That is a risky assumption given that the Last Call ends on Aug 4 which 
> is less than one month away and the TF has not yet been created.

From my understanding, the HTML WG's Last Call timeline doesn't matter if both the RDFa and Microdata specs in HTML5 are blocked indefinitely from publication as RECs until the Task Force decides a reasonable path forward. We will exit HTML WG Last Call with documents that will, at worst, be blocked from going to REC or at best, will have architectural issues logged against them during Candidate REC. What am I missing?

> I encourage you to provide specific more actionable changes that can be made as
> Last Call comments ASAP.

I could do that, but I'm concerned that it would be perceived as an attack against the Microdata group. I'm currently in the middle of trying to pull each of these groups together to try and figure out if there is a reasonable compromise that can be worked out. I can't be effective at doing that and logging "bugs" against the Microdata spec.

I have clearly outlined the differences between Microdata, RDFa and Microformats here:

http://manu.sporny.org/2011/uber-comparison-rdfa-md-uf/

I have a hard time calling these things "bugs" as they are really just use cases that are and are not supported by each mechanism. There are a few things that qualify as bugs, but the rest are design decisions based on a subset of use cases that each group decided to address.

The real bug is that the HTML WG is pushing two solutions forward that do effectively the same thing (from the perception of the majority of Web developers). This is confusing people, in that they don't know which one to pick. It is creating a situation where the early adopters are screwed when a search company like Google picks a winner, and where the rest of the folks that just want a single solution are waiting for the dust to settle before implementing. It's confusing the market and slowing adoption.

I say this knowing that I was one of the people advocating that the W3C publish two solutions to the same problem. Advocating this position was a mistake, in hindsight.

I will personally, (not on behalf of the RDF Web Apps WG) log bugs against Microdata if one of two things happen:

1) The Chairs of the HTML WG request that all design issues and bugs known to me are logged against Microdata.
2) Ian, Henri and the rest of the WHATWG folks ask me to log all design issues and bugs that have been identified over the past two years on Microdata into the HTML WG issue tracker.
Comment 5 Paul Cotton 2011-07-05 22:19:40 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > That is a risky assumption given that the Last Call ends on Aug 4 which 
> > is less than one month away and the TF has not yet been created.
> From my understanding, the HTML WG's Last Call timeline doesn't matter if both
> the RDFa and Microdata specs in HTML5 are blocked indefinitely from publication
> as RECs until the Task Force decides a reasonable path forward. We will exit
> HTML WG Last Call with documents that will, at worst, be blocked from going to
> REC or at best, will have architectural issues logged against them during
> Candidate REC. What am I missing?

I am going to respond to just the first part of your comment.

The TAG has filed a Last Call comment and this comment has been filed against both the RDFa and Microdata Last Call Working Drafts.  The WG Chairs intend on processing these comments according to our WG Decision Policy.  This means the bugs which have been assigned a Priority of P1 will be first processed by the respective specification Editors and then will be subject to escalation as per the Decision Policy.  

BTW, I see nothing in the TAG's comment that implies they intend to block these drafts from going forward.  I suppose it is possible that the TAG might want to file a Formal Objection if the HTML WG does not process these bugs to their satisfaction but we are a long ways away from that stage. 

/paulc
Comment 6 Philip J├Ągenstedt 2011-07-06 08:12:57 UTC
(In reply to comment #4)

> I could do that, but I'm concerned that it would be perceived as an attack
> against the Microdata group. I'm currently in the middle of trying to pull each
> of these groups together to try and figure out if there is a reasonable
> compromise that can be worked out. I can't be effective at doing that and
> logging "bugs" against the Microdata spec.

Please file bugs! There is no greater form of flattery in the spec world. I volunteer to eat my hat if anyone should get the least bit offended.
Comment 7 Andreas Kuckartz 2011-07-08 14:03:41 UTC
*** Bug 13100 has been marked as a duplicate of this bug. ***
Comment 8 Sam Ruby 2011-08-02 22:12:15 UTC
This bug was marked as P1 over 30 days ago, and still hasn't been RESOLVED.

Editor: please RESOLVE it ASAP.  NEEDSINFO and WONTFIX are valid resolutions for this part of the process.  We simply want to get this bug to a state where we are prepared to accept change proposals should anybody be inclined to produce such.
Comment 9 Manu Sporny 2011-08-03 20:20:28 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are
satisfied with this response, please change the state of this bug to CLOSED. If
you have additional information and would like the editor to reconsider, please
reopen this bug. If you would like to escalate the issue to the full HTML
Working Group, please add the TrackerRequest keyword to this bug, and suggest
title and text for the tracker issue; or you may create a tracker issue
yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Nothing Actionable Described

Change Description: Zero Specification Changes

Rationale:

While I wholeheartedly agree that there is a serious issue with the W3C publishing two specifications that do effectively the same things for structured data in HTML, and I agree with much of what is said in the W3C TAG note to the HTML WG, the TAG provided no actionable information in their note to the group. I do not have a firm grasp on what changes could be made to the HTML5+RDFa specification to alleviate the TAG's concerns.

We are re-evaluating changes that could be made to RDFa and Microdata currently as a result of the TAG note, and we are attempting to provide a set of options to the RDFa/Microdata Task Force when it forms, but no further guidance has been provided by the TAG since the note. We are waiting on them for something more actionable to be proposed.

I have filed all of the bugs that I can think of against Microdata, some of those were implied in the TAG note. I have asked Ian, Henri, Philip J. and a few other WHATWG folks to do the same for RDFa in the past and we've discussed those issues at length in the RDFa Working Group and the RDF Web Apps Working Group.

I feel that we have done all that we can. The TAG, or the RDFa/Microdata Task Force, will have to let us know of a further set of actionable items that will address the issues listed in the W3C TAG note. I am resolving this bug not because I believe that there isn't a problem, but because I am required to per the HTML WG bug processing policy and because there is nothing else that I can see that I can do as an editor.
Comment 10 Michael[tm] Smith 2011-08-04 05:05:55 UTC
mass-move component to LC1
Comment 11 Philippe Le Hegaret 2011-10-11 18:07:18 UTC
For information:

Proposed SWIG task forces on HTML Data, Web Schemas
Tue, 20 Sep 2011
http://lists.w3.org/Archives/Public/www-tag/2011Sep/0026.html

In particular, the HTML Data Task Force:
 http://www.w3.org/wiki/Html-data-tf

The task force MAY propose modifications in the form of bug reports and change proposals on the microdata and/or RDFa specifications, to help users to easily transition between the two syntaxes or use them together. As with all such comments, the ultimate decisions on implementing these will rest with the respective Working Groups.