This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 12891 - to RDF conversion should be in agreement with schema.org
Summary: to RDF conversion should be in agreement with schema.org
Status: RESOLVED DUPLICATE of bug 12713
Alias: None
Product: HTML WG
Classification: Unclassified
Component: pre-LC1 HTML Microdata (editor: Ian Hickson) (show other bugs)
Version: unspecified
Hardware: PC Windows NT
: P2 normal
Target Milestone: ---
Assignee: contributor
QA Contact: HTML WG Bugzilla archive list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-05 19:36 UTC by Giovanni Tummarello
Modified: 2011-06-08 19:57 UTC (History)
8 users (show)

See Also:


Attachments

Description Giovanni Tummarello 2011-06-05 19:36:30 UTC
Schema.org using microdata shows an RDF which makes sense (e.g. the URIs are correctly the same as those poposed on schema.org)see http://schema.org/docs/datamodel.html the RDFa example (just convert it to rdf)

but if the proposed algorithm is used the URIS would be really strange and incompatible with these.

"http://www.w3.org/1999/xhtml/microdata#http://example.com/a%23:q%20r".

it is really important to fix this algorithm since we do need implementations asap also driven by schema.org
Comment 1 Philip J├Ągenstedt 2011-06-07 10:25:10 UTC
From http://schema.org/docs/datamodel.html it doesn't look like they are using microdata at all. See also http://www.w3.org/Bugs/Public/show_bug.cgi?id=12713
Comment 2 Ian 'Hixie' Hickson 2011-06-08 19:57:53 UTC

*** This bug has been marked as a duplicate of bug 12713 ***