This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 12224 - Drop rel=pingback. The Pingback spec seems dead and unused, and redundant with the Referer header.
Summary: Drop rel=pingback. The Pingback spec seems dead and unused, and redundant wit...
Status: RESOLVED FIXED
Alias: None
Product: HTML WG
Classification: Unclassified
Component: LC1 HTML5 spec (show other bugs)
Version: unspecified
Hardware: Other other
: P3 normal
Target Milestone: ---
Assignee: Ian 'Hixie' Hickson
QA Contact: HTML WG Bugzilla archive list
URL: http://www.whatwg.org/specs/web-apps/...
Whiteboard:
Keywords: WGDecision
: 13031 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-02 19:58 UTC by contributor
Modified: 2011-09-04 17:45 UTC (History)
10 users (show)

See Also:


Attachments

Description contributor 2011-03-02 19:58:02 UTC
Specification: http://www.whatwg.org/specs/web-apps/current-work/complete/links.html
Section: http://www.whatwg.org/specs/web-apps/current-work/#link-type-pingback

Comment:
Drop rel=pingback. The Pingback spec seems dead and unused, and redundant with
the Referer header.

Posted from: 85.227.154.141
User agent: Opera/9.80 (Macintosh; Intel Mac OS X 10.5.8; U; en) Presto/2.7.62 Version/11.01
Comment 1 Julian Reschke 2011-03-02 20:12:38 UTC
Agreed to drop it (not necessarily because it's bad or not much used, but because it doesn't need to be defined in HTML).
Comment 2 Philip J├Ągenstedt 2011-03-02 21:42:33 UTC
Would that make <link rel=pingback> invalid? That would be unforunate, because it's actually used by WordPress:

<link rel="pingback" href="http://blog.foolip.org/xmlrpc.php" />

I haven't looked into it, but I assume that when you publish a blog post, WordPress fetches all linked pages and looks for <link rel=pingback> in order to make that magic work.
Comment 3 Ian 'Hixie' Hickson 2011-05-06 19:30:59 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: no spec change
Rationale: pingback is used by blogging software all over the place.
Comment 4 Julian Reschke 2011-05-06 19:46:04 UTC
(In reply to comment #3)
> Status: Rejected
> Change Description: no spec change
> Rationale: pingback is used by blogging software all over the place.

Yes. So? HTML5 doesn't define pingback, it just references the definition at 

  http://www.hixie.ch/specs/pingback/pingback

Isn't this what we have a registry for? Why repeat it in the HTML spec?
Comment 5 Ian 'Hixie' Hickson 2011-05-06 20:14:46 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: no spec change
Rationale: Any term that is well-established and used should go in the spec.

IMHO, we should to a state where the registry is just used to avoid name clashes in development, and once a feature is proved we should move it to the spec. I haven't set that up yet, but that's where I'm headed.
Comment 6 Julian Reschke 2011-05-06 20:20:45 UTC
Sorry, but I don't believe that's what the WG decided to do; in particular as the W3C HTML spec can't be continuously updated at the rate new relations would need it.
Comment 7 Ian 'Hixie' Hickson 2011-05-06 20:25:11 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Rejected
Change Description: no spec change
Rationale: Sure it can. That's what "continuous maintenance" means. It's not like we're going to stop working on HTML again.
Comment 8 Sam Ruby 2011-05-09 01:09:30 UTC
http://www.w3.org/html/wg/tracker/issues/165
Comment 9 Edward O'Connor 2011-05-09 16:55:32 UTC
For the record, as one of the main proponents of using the Microformats wiki's existing-rel-values page for our registry of rel values: I'm perfectly happy with Ian's plan to integrate proved values into the spec, and I don't believe that his doing so contradicts the ISSUE-27 decision.
Comment 10 Julian Reschke 2011-06-23 18:52:09 UTC
*** Bug 13031 has been marked as a duplicate of this bug. ***
Comment 11 Michael[tm] Smith 2011-08-04 05:16:43 UTC
mass-move component to LC1
Comment 12 Sam Ruby 2011-08-26 19:39:21 UTC
WG Decision: http://lists.w3.org/Archives/Public/public-html/2011Aug/0412.html

Change Proposal adopted by Amicable Consensus:
http://lists.w3.org/Archives/Public/public-html/2011Jul/0124.html
Comment 13 contributor 2011-09-04 17:45:47 UTC
Checked in as WHATWG revision r6534.
Check-in comment: Move rel=pingback registration from spec to wiki.
http://html5.org/tools/web-apps-tracker?from=6533&to=6534